# CVE-2023-28706: Apache Airflow Hive Provider Beeline Remote Command Execution


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Apr 2023
- **Updated:** 22 Oct 2024
- **Also known as:** GHSA-5cvg-9pp5-mxcj, PYSEC-2026-271

## What is CVE-2023-28706?

CVE-2023-28706 is a critical vulnerability in Apache Airflow Hive Provider, published on 7 Apr 2023. 

### Official description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider: before 6.0.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-28706?

3 open source packages ship an affected version, including apache-airflow-providers-apache-hive. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-apache-hive` | PyPI | All versions | 6.0.0 |
| `apache-airflow-providers-apache-hive` | PyPI | All versions | 6.0.0 |
| `apache-airflow-providers-apache-hive` | PyPI | All versions | 6.0.0 |

Products: Apache Airflow Hive Provider.

## How do I fix CVE-2023-28706?

Upgrade apache-airflow-providers-apache-hive to 6.0.0 or later.

## Is CVE-2023-28706 being exploited?

There is no known exploitation of CVE-2023-28706 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28706 and fix it if it is affected.

What it is: CVE-2023-28706 is a critical vulnerability in Apache Airflow Hive Provider, published on 7 Apr 2023. 
Exploitation: There is no known exploitation of CVE-2023-28706 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 6.0.0
- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 6.0.0
- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28706/ (Markdown: https://insights.sbomify.com/CVE-2023-28706/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28706
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28706
- OSV: https://osv.dev/vulnerability/CVE-2023-28706

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28706/
Summaries are generated and may contain mistakes; the official description above is the record.
