{"answers":{"affected":"3 open source packages ship an affected version, including apache-airflow-providers-apache-spark. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28710 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-apache-spark to 4.0.1 or later.","what":"CVE-2023-28710 is a high-severity path traversal vulnerability in Apache Airflow Spark Provider, published on 7 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-28710 and fix it if it is affected.\n\nWhat it is: CVE-2023-28710 is a high-severity path traversal vulnerability in Apache Airflow Spark Provider, published on 7 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-28710 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-apache-spark (PyPI): affected all versions; fixed in 4.0.1\n- apache-airflow-providers-apache-spark (PyPI): affected all versions; fixed in 4.0.1\n- apache-airflow-providers-apache-spark (PyPI): affected all versions; fixed in 4.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28710/ (Markdown: https://insights.sbomify.com/CVE-2023-28710/index.md)","id":"CVE-2023-28710","markdown":"https://insights.sbomify.com/CVE-2023-28710/index.md","name":"CVE-2023-28710","record":{"aliases":["GHSA-ffj9-4crc-q7wf","PYSEC-2026-1140"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Airflow Spark Provider","requires_auth":"none","summary":"An attacker can read arbitrary files from the server via improper input validation in the Apache Airflow Spark Provider JDBC connection.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-apache-spark","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Spark Provider.This issue affects Apache Airflow Spark Provider: before 4.0.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow Spark Provider Arbitrary File Read via JDBC","id":"CVE-2023-28710","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2023"},"n_packages":3,"n_references":3,"next":{"headline":"Denial of service in Hyperscan Library maintained by Intel(R)","id":"CVE-2023-28711"},"packages":[{"ecosystem":"PyPI","fixed":["4.0.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-spark","purl":null,"source":"GHSA-ffj9-4crc-q7wf"},{"ecosystem":"PyPI","fixed":["4.0.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-spark","purl":"pkg:pypi/apache-airflow-providers-apache-spark","source":"GHSA-ffj9-4crc-q7wf"},{"ecosystem":"PyPI","fixed":["4.0.1"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-spark","purl":"pkg:pypi/apache-airflow-providers-apache-spark","source":"PYSEC-2026-1140"}],"prev":{"headline":"Apache Tomcat: Fix for CVE-2023-24998 is incomplete","id":"CVE-2023-28709"},"products":["Apache Airflow Spark Provider"],"published":"2023-04-07","related":[{"cvss_score":7.5,"headline":"Apache Airflow Spark Provider Arbitrary File Read via JDBC","id":"CVE-2023-40272","kev_date_added":null,"published":"2023-08-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-22","vendors":["Apache Software Foundation"]},"summary":"An attacker can read arbitrary files from the server via improper input validation in the Apache Airflow Spark Provider JDBC connection.","url":"https://insights.sbomify.com/CVE-2023-28710/"}