# CVE-2023-28710: Apache Airflow Spark Provider Arbitrary File Read via JDBC

> An attacker can read arbitrary files from the server via improper input validation in the Apache Airflow Spark Provider JDBC connection.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2023
- **Updated:** 22 Oct 2024
- **Also known as:** GHSA-ffj9-4crc-q7wf, PYSEC-2026-1140

## What is CVE-2023-28710?

CVE-2023-28710 is a high-severity path traversal vulnerability in Apache Airflow Spark Provider, published on 7 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Spark Provider.This issue affects Apache Airflow Spark Provider: before 4.0.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-28710?

3 open source packages ship an affected version, including apache-airflow-providers-apache-spark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-apache-spark` | PyPI | All versions | 4.0.1 |
| `apache-airflow-providers-apache-spark` | PyPI | All versions | 4.0.1 |
| `apache-airflow-providers-apache-spark` | PyPI | All versions | 4.0.1 |

Products: Apache Apache-Airflow-Providers-Apache-Spark.

## How do I fix CVE-2023-28710?

Upgrade apache-airflow-providers-apache-spark to 4.0.1 or later.

## Is CVE-2023-28710 being exploited?

There is no known exploitation of CVE-2023-28710 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow Spark Provider

- [CVE-2023-40272](https://insights.sbomify.com/CVE-2023-40272/): Apache Airflow Spark Provider Arbitrary File Read via JDBC (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28710 and fix it if it is affected.

What it is: CVE-2023-28710 is a high-severity path traversal vulnerability in Apache Airflow Spark Provider, published on 7 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28710 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-apache-spark (PyPI): affected all versions; fixed in 4.0.1
- apache-airflow-providers-apache-spark (PyPI): affected all versions; fixed in 4.0.1
- apache-airflow-providers-apache-spark (PyPI): affected all versions; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28710/ (Markdown: https://insights.sbomify.com/CVE-2023-28710/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28710
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28710
- OSV: https://osv.dev/vulnerability/CVE-2023-28710

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28710/
Summaries are generated and may contain mistakes; the official description above is the record.
