# CVE-2023-28755: Ruby URI component ReDoS issue

> Attackers can cause denial of service by sending specially crafted URLs that trigger excessive CPU usage in the Ruby URI parser.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2023
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2023-28755, CLEANSTART-2026-KX08240, CLSA-2026-1779099998, DEBIAN-CVE-2023-28755, ECHO-97f1-838f-206b, GHSA-hv5j-3h9f-99c2, UBUNTU-CVE-2023-28755, openSUSE-SU-2024:12828-1, openSUSE-SU-2024:12849-1

## What is CVE-2023-28755?

CVE-2023-28755 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 31 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. The URI parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to URI objects. The fixed versions are 0.12.1, 0.11.1, 0.10.2 and 0.10.0.1.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2023-28755?

8 open source packages ship an affected version, including uri. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `uri` | RubyGems | All versions | 0.10.0.1 |
| `uri` | RubyGems | All versions | 0.10.0.1 |
| `uri` | RubyGems | From 0.10.1 | 0.10.2 |
| `uri` | RubyGems | From 0.10.1 | 0.10.2 |
| `uri` | RubyGems | From 0.11.0 | 0.11.1 |
| `uri` | RubyGems | From 0.11.0 | 0.11.1 |
| `uri` | RubyGems | From 0.12.0 | 0.12.1 |
| `uri` | RubyGems | From 0.12.0 | 0.12.1 |
| `ruby3.1` | openSUSE:Tumbleweed | All versions | 3.1.4-1.1 |
| `ruby3.2` | openSUSE:Tumbleweed | All versions | 3.2.2-1.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Ruby-Lang Uri.

## How do I fix CVE-2023-28755?

Upgrade uri to a fixed version for your release line: 0.10.0.1, 0.10.2, 0.11.1 or 0.12.1.

## Is CVE-2023-28755 being exploited?

There is no known exploitation of CVE-2023-28755 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28755 and fix it if it is affected.

What it is: CVE-2023-28755 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 31 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28755 in the wild and no public exploit code.

Affected packages and fixed versions:
- uri (RubyGems): affected all versions; fixed in 0.10.0.1
- uri (RubyGems): affected all versions; fixed in 0.10.0.1
- uri (RubyGems): affected from 0.10.1; fixed in 0.10.2
- uri (RubyGems): affected from 0.10.1; fixed in 0.10.2
- uri (RubyGems): affected from 0.11.0; fixed in 0.11.1
- uri (RubyGems): affected from 0.11.0; fixed in 0.11.1
- uri (RubyGems): affected from 0.12.0; fixed in 0.12.1
- uri (RubyGems): affected from 0.12.0; fixed in 0.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28755/ (Markdown: https://insights.sbomify.com/CVE-2023-28755/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28755
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28755
- OSV: https://osv.dev/vulnerability/CVE-2023-28755

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28755/
Summaries are generated and may contain mistakes; the official description above is the record.
