CVE-2023-28819 Concrete CMS (previously concrete5) is vulnerable to stored XSS in uploaded file and folder names

Low 3.5 Published Updated

Attackers can inject malicious scripts via uploaded file and folder names in Concrete CMS, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-28819?

CVE-2023-28819 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 28 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Concrete CMS (previously concrete5) versions 8.5.12 and below, 9.0.0 through 9.0.2 is vulnerable to Stored XSS in uploaded file and folder names.

Weakness: CWE-79

Which versions are affected by CVE-2023-28819?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.

PackageAffectedFixed in
concrete5/concrete5 PackagistAll versions9.1.0
concrete5/concrete5 PackagistAll versions9.1.0

Products include Concretecms Concrete Cms.

How do I fix CVE-2023-28819?

Upgrade concrete5/concrete5 to 9.1.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-28819 being exploited?

There is no known exploitation of CVE-2023-28819 in the wild and no public exploit code.

All Concretecms Concrete Cms vulnerabilities

Sources

Also known as GHSA-474f-mcjv-pgrm.

Is CVE-2023-28819 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free