# CVE-2023-28820: Stored cross site scripting in RSS displayer

> Attackers can inject malicious scripts via unsanitized RSS links, potentially stealing user sessions or executing code in Concrete CMS.

- **Severity:** Low 2.0 (`CVSS:3.1/AC:H/AV:N/A:N/C:L/I:N/PR:H/S:U/UI:R`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Apr 2023
- **Updated:** 31 Jan 2025
- **Also known as:** GHSA-fgxj-g7x3-85cq

## What is CVE-2023-28820?

CVE-2023-28820 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 28 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Concrete CMS (previously concrete5) before 9.1 is vulnerable to stored XSS in RSS Displayer via the href attribute because the link element input was not sanitized.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-28820?

2 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 9.1.0 |
| `concrete5/concrete5` | Packagist | All versions | 9.1.0 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2023-28820?

Upgrade concrete5/concrete5 to 9.1.0 or later.

## Is CVE-2023-28820 being exploited?

There is no known exploitation of CVE-2023-28820 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28820 and fix it if it is affected.

What it is: CVE-2023-28820 is a low-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 28 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-28820 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.1.0
- concrete5/concrete5 (Packagist): affected all versions; fixed in 9.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28820/ (Markdown: https://insights.sbomify.com/CVE-2023-28820/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28820
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28820
- OSV: https://osv.dev/vulnerability/CVE-2023-28820

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28820/
Summaries are generated and may contain mistakes; the official description above is the record.
