CVE-2023-28836 Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views
A stored XSS vulnerability in Wagtail ModelAdmin views allows limited editors to execute scripts in higher-privilege users' sessions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-28836?
CVE-2023-28836 is a medium-severity cross-site scripting vulnerability in wagtail, published on 3 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Wagtail is an open source content management system built on Django. Starting in version 1.5 and prior to versions 4.1.4 and 4.2.2, a stored cross-site scripting (XSS) vulnerability exists on ModelAdmin views within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft pages and documents that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, and only affects sites with ModelAdmin enabled. For page, the vulnerability is in the "Choose a parent page" ModelAdmin view (`ChooseParentView`), available when managing pages via ModelAdmin. For documents, the vulnerability is in the ModelAdmin Inspect view (`InspectView`) when displaying document fields. Patched versions have been released as Wagtail 4.1.4 and Wagtail 4.2.2. Site owners who are unable to upgrade to the new versions can disable or override the corresponding functionality.
Weakness: CWE-79
Which versions are affected by CVE-2023-28836?
5 open source packages ship an affected version, including wagtail. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
wagtail PyPI | From 1.5 | 4.1.4, 4.2.2 |
wagtail PyPI | From 1.5 | 4.1.4 |
wagtail PyPI | From 1.5 | 4.1.4 |
wagtail PyPI | From 4.2 | 4.2.2 |
wagtail PyPI | From 4.2 | 4.2.2 |
Products include Torchbox Wagtail.
How do I fix CVE-2023-28836?
Upgrade wagtail to a fixed version for your release line: 4.1.4 or 4.2.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-28836 being exploited?
There is no known exploitation of CVE-2023-28836 in the wild and no public exploit code.
Other vulnerabilities in wagtail
- CVE-2026-54263 Wagtail: Reflected XSS in dynamic image URL generator view
- CVE-2026-54261 Wagtail: Improper permission handling in image preview
- CVE-2026-44197 Wagtail: Improper permission handling when comparing revisions
- CVE-2026-44199 Wagtail: Improper permission handling when deleting form submissions
- CVE-2026-44200 Wagtail: Improper permission handling when copying pages
Sources
Also known as GHSA-5286-f2rf-35c2, PYSEC-2023-55.