{"answers":{"affected":"5 open source packages ship an affected version, including wagtail. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28836 in the wild and no public exploit code.","fix":"Upgrade wagtail to a fixed version for your release line: 4.1.4 or 4.2.2.","what":"CVE-2023-28836 is a medium-severity cross-site scripting vulnerability in wagtail, published on 3 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-28836 and fix it if it is affected.\n\nWhat it is: CVE-2023-28836 is a medium-severity cross-site scripting vulnerability in wagtail, published on 3 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-28836 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wagtail (PyPI): affected from 1.5; fixed in 4.1.4, 4.2.2\n- wagtail (PyPI): affected from 1.5; fixed in 4.1.4\n- wagtail (PyPI): affected from 1.5; fixed in 4.1.4\n- wagtail (PyPI): affected from 4.2; fixed in 4.2.2\n- wagtail (PyPI): affected from 4.2; fixed in 4.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28836/ (Markdown: https://insights.sbomify.com/CVE-2023-28836/index.md)","id":"CVE-2023-28836","markdown":"https://insights.sbomify.com/CVE-2023-28836/index.md","name":"CVE-2023-28836","record":{"aliases":["GHSA-5286-f2rf-35c2","PYSEC-2023-55"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Wagtail CMS","requires_auth":"high_privilege","summary":"A stored XSS vulnerability in Wagtail ModelAdmin views allows limited editors to execute scripts in higher-privilege users' sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wagtail","vendor":"torchbox"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Wagtail is an open source content management system built on Django. Starting in version 1.5 and prior to versions 4.1.4 and 4.2.2, a stored cross-site scripting (XSS) vulnerability exists on ModelAdmin views within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft pages and documents that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, and only affects sites with ModelAdmin enabled. For page, the vulnerability is in the \"Choose a parent page\" ModelAdmin view (`ChooseParentView`), available when managing pages via ModelAdmin. For documents, the vulnerability is in the ModelAdmin Inspect view (`InspectView`) when displaying document fields. Patched versions have been released as Wagtail 4.1.4 and Wagtail 4.2.2. Site owners who are unable to upgrade to the new versions can disable or override the corresponding functionality.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views","id":"CVE-2023-28836","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":5,"n_references":8,"next":{"headline":"Wagtail vulnerable to denial-of-service via memory exhaustion when uploading large files","id":"CVE-2023-28837"},"packages":[{"ecosystem":"PyPI","fixed":["4.1.4","4.2.2"],"introduced":["1.5","4.2"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"PYSEC-2023-55"},{"ecosystem":"PyPI","fixed":["4.1.4"],"introduced":["1.5"],"last_affected":[],"package":"wagtail","purl":null,"source":"GHSA-5286-f2rf-35c2"},{"ecosystem":"PyPI","fixed":["4.1.4"],"introduced":["1.5"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"GHSA-5286-f2rf-35c2"},{"ecosystem":"PyPI","fixed":["4.2.2"],"introduced":["4.2"],"last_affected":[],"package":"wagtail","purl":null,"source":"GHSA-5286-f2rf-35c2"},{"ecosystem":"PyPI","fixed":["4.2.2"],"introduced":["4.2"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"GHSA-5286-f2rf-35c2"}],"prev":{"headline":"Insecure randomness for default password in nextcloud","id":"CVE-2023-28835"},"products":["wagtail"],"published":"2023-04-03","related":[{"cvss_score":7.3,"headline":"Wagtail: Reflected XSS in dynamic image URL generator view","id":"CVE-2026-54263","kev_date_added":null,"published":"2026-07-01"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling in image preview","id":"CVE-2026-54261","kev_date_added":null,"published":"2026-07-01"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling when comparing revisions","id":"CVE-2026-44197","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling when deleting form submissions","id":"CVE-2026-44199","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling when copying pages","id":"CVE-2026-44200","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":6.5,"headline":"Wagtail regular expression denial-of-service via search query parsing","id":"CVE-2024-39317","kev_date_added":null,"published":"2024-07-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["wagtail"]},"summary":"A stored XSS vulnerability in Wagtail ModelAdmin views allows limited editors to execute scripts in higher-privilege users' sessions.","url":"https://insights.sbomify.com/CVE-2023-28836/"}