# CVE-2023-28836: Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views

> A stored XSS vulnerability in Wagtail ModelAdmin views allows limited editors to execute scripts in higher-privilege users' sessions.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Apr 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-5286-f2rf-35c2, PYSEC-2023-55

## What is CVE-2023-28836?

CVE-2023-28836 is a medium-severity cross-site scripting vulnerability in wagtail, published on 3 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Wagtail is an open source content management system built on Django. Starting in version 1.5 and prior to versions 4.1.4 and 4.2.2, a stored cross-site scripting (XSS) vulnerability exists on ModelAdmin views within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft pages and documents that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, and only affects sites with ModelAdmin enabled. For page, the vulnerability is in the "Choose a parent page" ModelAdmin view (`ChooseParentView`), available when managing pages via ModelAdmin. For documents, the vulnerability is in the ModelAdmin Inspect view (`InspectView`) when displaying document fields. Patched versions have been released as Wagtail 4.1.4 and Wagtail 4.2.2. Site owners who are unable to upgrade to the new versions can disable or override the corresponding functionality.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-28836?

5 open source packages ship an affected version, including wagtail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail` | PyPI | From 1.5 | 4.1.4, 4.2.2 |
| `wagtail` | PyPI | From 1.5 | 4.1.4 |
| `wagtail` | PyPI | From 1.5 | 4.1.4 |
| `wagtail` | PyPI | From 4.2 | 4.2.2 |
| `wagtail` | PyPI | From 4.2 | 4.2.2 |

Products: Torchbox Wagtail.

## How do I fix CVE-2023-28836?

Upgrade wagtail to a fixed version for your release line: 4.1.4 or 4.2.2.

## Is CVE-2023-28836 being exploited?

There is no known exploitation of CVE-2023-28836 in the wild and no public exploit code.

## Other vulnerabilities in wagtail

- [CVE-2026-54263](https://insights.sbomify.com/CVE-2026-54263/): Wagtail: Reflected XSS in dynamic image URL generator view (high 7.3)
- [CVE-2026-54261](https://insights.sbomify.com/CVE-2026-54261/): Wagtail: Improper permission handling in image preview (medium 6.5)
- [CVE-2026-44197](https://insights.sbomify.com/CVE-2026-44197/): Wagtail: Improper permission handling when comparing revisions (medium 6.5)
- [CVE-2026-44199](https://insights.sbomify.com/CVE-2026-44199/): Wagtail: Improper permission handling when deleting form submissions (medium 6.5)
- [CVE-2026-44200](https://insights.sbomify.com/CVE-2026-44200/): Wagtail: Improper permission handling when copying pages (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28836 and fix it if it is affected.

What it is: CVE-2023-28836 is a medium-severity cross-site scripting vulnerability in wagtail, published on 3 Apr 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-28836 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail (PyPI): affected from 1.5; fixed in 4.1.4, 4.2.2
- wagtail (PyPI): affected from 1.5; fixed in 4.1.4
- wagtail (PyPI): affected from 1.5; fixed in 4.1.4
- wagtail (PyPI): affected from 4.2; fixed in 4.2.2
- wagtail (PyPI): affected from 4.2; fixed in 4.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28836/ (Markdown: https://insights.sbomify.com/CVE-2023-28836/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28836
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28836
- OSV: https://osv.dev/vulnerability/CVE-2023-28836

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28836/
Summaries are generated and may contain mistakes; the official description above is the record.
