CVE-2023-28837 Wagtail vulnerable to denial-of-service via memory exhaustion when uploading large files
Admin users can cause denial of service by uploading large files that exhaust server memory during processing.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-28837?
CVE-2023-28837 is a medium-severity denial of service vulnerability in wagtail, published on 3 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Wagtail is an open source content management system built on Django. Prior to versions 4.1.4 and 4.2.2, a memory exhaustion bug exists in Wagtail's handling of uploaded images and documents. For both images and documents, files are loaded into memory during upload for additional processing. A user with access to upload images or documents through the Wagtail admin interface could upload a file so large that it results in a crash of denial of service.
The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. It can only be exploited by admin users with permission to upload images or documents.
Image uploads are restricted to 10MB by default, however this validation only happens on the frontend and on the backend after the vulnerable code.
Patched versions have been released as Wagtail 4.1.4 and Wagtail 4.2.2). Site owners who are unable to upgrade to the new versions are encouraged to add extra protections outside of Wagtail to limit the size of uploaded files.
Which versions are affected by CVE-2023-28837?
5 open source packages ship an affected version, including wagtail. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
wagtail PyPI | All versions | 4.1.4 |
wagtail PyPI | All versions | 4.1.4 |
wagtail PyPI | From 4.2 | 4.2.2, 4.1.4 |
wagtail PyPI | From 4.2 | 4.2.2 |
wagtail PyPI | From 4.2 | 4.2.2 |
Products include Torchbox Wagtail.
How do I fix CVE-2023-28837?
Upgrade wagtail to a fixed version for your release line: 4.1.4 or 4.2.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-28837 being exploited?
There is no known exploitation of CVE-2023-28837 in the wild and no public exploit code.
Other vulnerabilities in wagtail
- CVE-2026-54263 Wagtail: Reflected XSS in dynamic image URL generator view
- CVE-2026-54261 Wagtail: Improper permission handling in image preview
- CVE-2026-44197 Wagtail: Improper permission handling when comparing revisions
- CVE-2026-44199 Wagtail: Improper permission handling when deleting form submissions
- CVE-2026-44200 Wagtail: Improper permission handling when copying pages
Sources
Also known as GHSA-33pv-vcgh-jfg9, PYSEC-2023-56.