# CVE-2023-28837: Wagtail vulnerable to denial-of-service via memory exhaustion when uploading large files

> Admin users can cause denial of service by uploading large files that exhaust server memory during processing.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2023
- **Updated:** 11 Feb 2025
- **Also known as:** GHSA-33pv-vcgh-jfg9, PYSEC-2023-56

## What is CVE-2023-28837?

CVE-2023-28837 is a medium-severity denial of service vulnerability in wagtail, published on 3 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Wagtail is an open source content management system built on Django. Prior to versions 4.1.4 and 4.2.2, a memory exhaustion bug exists in Wagtail's handling of uploaded images and documents. For both images and documents, files are loaded into memory during upload for additional processing. A user with access to upload images or documents through the Wagtail admin interface could upload a file so large that it results in a crash of denial of service.

The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. It can only be exploited by admin users with permission to upload images or documents.

Image uploads are restricted to 10MB by default, however this validation only happens on the frontend and on the backend after the vulnerable code. 

Patched versions have been released as Wagtail 4.1.4 and Wagtail 4.2.2). Site owners who are unable to upgrade to the new versions are encouraged to add extra protections outside of Wagtail to limit the size of uploaded files.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-28837?

5 open source packages ship an affected version, including wagtail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail` | PyPI | All versions | 4.1.4 |
| `wagtail` | PyPI | All versions | 4.1.4 |
| `wagtail` | PyPI | From 4.2 | 4.2.2, 4.1.4 |
| `wagtail` | PyPI | From 4.2 | 4.2.2 |
| `wagtail` | PyPI | From 4.2 | 4.2.2 |

Products: Torchbox Wagtail.

## How do I fix CVE-2023-28837?

Upgrade wagtail to a fixed version for your release line: 4.1.4 or 4.2.2.

## Is CVE-2023-28837 being exploited?

There is no known exploitation of CVE-2023-28837 in the wild and no public exploit code.

## Other vulnerabilities in wagtail

- [CVE-2026-54263](https://insights.sbomify.com/CVE-2026-54263/): Wagtail: Reflected XSS in dynamic image URL generator view (high 7.3)
- [CVE-2026-54261](https://insights.sbomify.com/CVE-2026-54261/): Wagtail: Improper permission handling in image preview (medium 6.5)
- [CVE-2026-44197](https://insights.sbomify.com/CVE-2026-44197/): Wagtail: Improper permission handling when comparing revisions (medium 6.5)
- [CVE-2026-44199](https://insights.sbomify.com/CVE-2026-44199/): Wagtail: Improper permission handling when deleting form submissions (medium 6.5)
- [CVE-2026-44200](https://insights.sbomify.com/CVE-2026-44200/): Wagtail: Improper permission handling when copying pages (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28837 and fix it if it is affected.

What it is: CVE-2023-28837 is a medium-severity denial of service vulnerability in wagtail, published on 3 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28837 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail (PyPI): affected all versions; fixed in 4.1.4
- wagtail (PyPI): affected all versions; fixed in 4.1.4
- wagtail (PyPI): affected from 4.2; fixed in 4.2.2, 4.1.4
- wagtail (PyPI): affected from 4.2; fixed in 4.2.2
- wagtail (PyPI): affected from 4.2; fixed in 4.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28837/ (Markdown: https://insights.sbomify.com/CVE-2023-28837/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28837
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28837
- OSV: https://osv.dev/vulnerability/CVE-2023-28837

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28837/
Summaries are generated and may contain mistakes; the official description above is the record.
