{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/perspective-editor. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28850 in the wild and no public exploit code.","fix":"Upgrade pimcore/perspective-editor to 1.5.1 or later.","what":"CVE-2023-28850 is a medium-severity cross-site scripting vulnerability in pimcore perspective-editor, published on 3 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-28850 and fix it if it is affected.\n\nWhat it is: CVE-2023-28850 is a medium-severity cross-site scripting vulnerability in pimcore perspective-editor, published on 3 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-28850 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pimcore/perspective-editor (Packagist): affected all versions; fixed in 1.5.1\n- pimcore/perspective-editor (Packagist): affected all versions; fixed in 1.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28850/ (Markdown: https://insights.sbomify.com/CVE-2023-28850/index.md)","id":"CVE-2023-28850","markdown":"https://insights.sbomify.com/CVE-2023-28850/index.md","name":"CVE-2023-28850","record":{"aliases":["GHSA-fq8q-55v3-2986"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Pimcore Perspective Editor","requires_auth":"none","summary":"Attackers can inject scripts into perspective names to steal cookies and hijack user accounts in Pimcore Perspective Editor.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"perspective_editor","vendor":"pimcore"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Pimcore Perspective Editor provides an editor for Pimcore that allows users to add/remove/edit custom views and perspectives. This vulnerability has the potential to steal a user's cookie and gain unauthorized access to that user's account through the stolen cookie or redirect users to other malicious sites. Version 1.5.1 has a patch. As a workaround, one may apply the patch manually.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pimcore Perspective Editor vulnerable to Cross-site Scripting in perspective name","id":"CVE-2023-28850","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Silverstripe Form Capture vulnerable to Stored Cross-Site Scripting","id":"CVE-2023-28851"},"packages":[{"ecosystem":"Packagist","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"pimcore/perspective-editor","purl":null,"source":"GHSA-fq8q-55v3-2986"},{"ecosystem":"Packagist","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"pimcore/perspective-editor","purl":"pkg:composer/pimcore/perspective-editor","source":"GHSA-fq8q-55v3-2986"}],"prev":{"headline":"GLPI vulnerable to SQL injection and Stored XSS via inventory agent request","id":"CVE-2023-28849"},"products":["perspective-editor"],"published":"2023-04-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-11","vendors":["pimcore"]},"summary":"Attackers can inject scripts into perspective names to steal cookies and hijack user accounts in Pimcore Perspective Editor.","url":"https://insights.sbomify.com/CVE-2023-28850/"}