# CVE-2023-28850: Pimcore Perspective Editor vulnerable to Cross-site Scripting in perspective name

> Attackers can inject scripts into perspective names to steal cookies and hijack user accounts in Pimcore Perspective Editor.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Apr 2023
- **Updated:** 11 Feb 2025
- **Also known as:** GHSA-fq8q-55v3-2986

## What is CVE-2023-28850?

CVE-2023-28850 is a medium-severity cross-site scripting vulnerability in pimcore perspective-editor, published on 3 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Pimcore Perspective Editor provides an editor for Pimcore that allows users to add/remove/edit custom views and perspectives. This vulnerability has the potential to steal a user's cookie and gain unauthorized access to that user's account through the stolen cookie or redirect users to other malicious sites. Version 1.5.1 has a patch. As a workaround, one may apply the patch manually.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-28850?

2 open source packages ship an affected version, including pimcore/perspective-editor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/perspective-editor` | Packagist | All versions | 1.5.1 |
| `pimcore/perspective-editor` | Packagist | All versions | 1.5.1 |

Products: Pimcore Perspective Editor.

## How do I fix CVE-2023-28850?

Upgrade pimcore/perspective-editor to 1.5.1 or later.

## Is CVE-2023-28850 being exploited?

There is no known exploitation of CVE-2023-28850 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28850 and fix it if it is affected.

What it is: CVE-2023-28850 is a medium-severity cross-site scripting vulnerability in pimcore perspective-editor, published on 3 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-28850 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/perspective-editor (Packagist): affected all versions; fixed in 1.5.1
- pimcore/perspective-editor (Packagist): affected all versions; fixed in 1.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28850/ (Markdown: https://insights.sbomify.com/CVE-2023-28850/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28850
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28850
- OSV: https://osv.dev/vulnerability/CVE-2023-28850

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28850/
Summaries are generated and may contain mistakes; the official description above is the record.
