CVE-2023-28853 Mastodon's blind LDAP injection in login allows the attacker to leak arbitrary attributes from LDAP database
Attackers can leak arbitrary LDAP attributes via blind injection during login if LDAP authentication is enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-28853?
CVE-2023-28853 is a high-severity vulnerability in mastodon, published on 4 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mastodon is a free, open-source social network server based on ActivityPub Mastodon allows configuration of LDAP for authentication. Starting in version 2.5.0 and prior to versions 3.5.8, 4.0.4, and 4.1.2, the LDAP query made during login is insecure and the attacker can perform LDAP injection attack to leak arbitrary attributes from LDAP database. This issue is fixed in versions 3.5.8, 4.0.4, and 4.1.2.
Which versions are affected by CVE-2023-28853?
1 open source package ship an affected version, including mastodon. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mastodon Bitnami | From 2.5.0 | 3.5.8, 4.0.4, 4.1.2 |
Products include Joinmastodon Mastodon.
How do I fix CVE-2023-28853?
Upgrade mastodon to a fixed version for your release line: 3.5.8, 4.0.4 or 4.1.2.
Is CVE-2023-28853 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28853 exists.
Other vulnerabilities in mastodon
- CVE-2023-36460 Mastodon vulnerable to arbitrary file creation through media attachments
- CVE-2022-2166 Improper Restriction of Excessive Authentication Attempts in mastodon/mastodon
- CVE-2022-24307 Missing authorization in n/a
- CVE-2018-21018 Auth bypass in n/a
- CVE-2024-23832 Mastodon Remote user impersonation and takeover
Sources
Also known as BIT-mastodon-2023-28853, GHSA-38g9-pfm9-gfqv.