CVE-2023-28858 redis-py Race Condition vulnerability
An attacker can read response data from unrelated requests due to a connection handling flaw in the async Redis client.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-28858?
CVE-2023-28858 is a low-severity vulnerability in n/a, published on 26 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
redis-py before 4.5.3 leaves a connection open after canceling an async Redis command at an inopportune time, and can send response data to the client of an unrelated request in an off-by-one manner. NOTE: this CVE Record was initially created in response to reports about ChatGPT, and 4.3.6, 4.4.3, and 4.5.3 were released (changing the behavior for pipeline operations); however, please see CVE-2023-28859 about addressing data leakage across AsyncIO connections in general.
Weakness: CWE-193
Which versions are affected by CVE-2023-28858?
7 open source packages ship an affected version, including redis. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
redis PyPI | From 4.2.0 | 4.3.6, 4.4.3, 4.5.3 |
redis PyPI | From 4.2.0 | 4.3.6 |
redis PyPI | From 4.2.0 | 4.3.6 |
redis PyPI | From 4.4.0 | 4.4.3 |
redis PyPI | From 4.4.0 | 4.4.3 |
redis PyPI | From 4.5.0 | 4.5.3 |
1 more packages
redis PyPI | From 4.5.0 | 4.5.3 |
Products include Redis Redis-Py.
How do I fix CVE-2023-28858?
Upgrade redis to a fixed version for your release line: 4.3.6, 4.4.3 or 4.5.3.
Is CVE-2023-28858 being exploited?
There is no known exploitation of CVE-2023-28858 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2023-28858, GHSA-24wv-mv5m-xv4h, PYSEC-2023-45, UBUNTU-CVE-2023-28858.