# CVE-2023-28867: GraphQL Java vulnerable to stack consumption

> An attacker can cause a denial of service in applications using GraphQL Java by sending a crafted query that exhausts stack resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2023
- **Updated:** 19 Feb 2025
- **Also known as:** GHSA-p4qx-6w5p-4rj2, ROOT-APP-MAVEN-CVE-2023-28867

## What is CVE-2023-28867?

CVE-2023-28867 is a high-severity denial of service vulnerability in n/a, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In GraphQL Java (aka graphql-java) before 20.1, an attacker can send a crafted GraphQL query that causes stack consumption. The fixed versions are 20.1, 19.4, 18.4, 17.5, and 0.0.0-2023-03-20T01-49-44-80e3135.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-28867?

10 open source packages ship an affected version, including com.graphql-java:graphql-java. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.graphql-java:graphql-java` | Maven | All versions | 0.0.0-2023-03-20T01-49-44-80e3135 |
| `com.graphql-java:graphql-java` | Maven | All versions | 0.0.0-2023-03-20T01-49-44-80e3135 |
| `com.graphql-java:graphql-java` | Maven | From 1.2 | 17.5 |
| `com.graphql-java:graphql-java` | Maven | From 1.2 | 17.5 |
| `com.graphql-java:graphql-java` | Maven | From 18.0 | 18.4 |
| `com.graphql-java:graphql-java` | Maven | From 18.0 | 18.4 |
| `com.graphql-java:graphql-java` | Maven | From 19.0 | 19.4 |
| `com.graphql-java:graphql-java` | Maven | From 19.0 | 19.4 |
| `com.graphql-java:graphql-java` | Maven | From 20.0 | 20.1 |
| `com.graphql-java:graphql-java` | Maven | From 20.0 | 20.1 |

Products: Graphql-Java Graphql-Java.

## How do I fix CVE-2023-28867?

Upgrade com.graphql-java:graphql-java to a fixed version for your release line: 0.0.0-2023-03-20T01-49-44-80e3135, 17.5, 18.4 or 19.4.

## Is CVE-2023-28867 being exploited?

There is no known exploitation of CVE-2023-28867 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28867 and fix it if it is affected.

What it is: CVE-2023-28867 is a high-severity denial of service vulnerability in n/a, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28867 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.graphql-java:graphql-java (Maven): affected all versions; fixed in 0.0.0-2023-03-20T01-49-44-80e3135
- com.graphql-java:graphql-java (Maven): affected all versions; fixed in 0.0.0-2023-03-20T01-49-44-80e3135
- com.graphql-java:graphql-java (Maven): affected from 1.2; fixed in 17.5
- com.graphql-java:graphql-java (Maven): affected from 1.2; fixed in 17.5
- com.graphql-java:graphql-java (Maven): affected from 18.0; fixed in 18.4
- com.graphql-java:graphql-java (Maven): affected from 18.0; fixed in 18.4
- com.graphql-java:graphql-java (Maven): affected from 19.0; fixed in 19.4
- com.graphql-java:graphql-java (Maven): affected from 19.0; fixed in 19.4
- com.graphql-java:graphql-java (Maven): affected from 20.0; fixed in 20.1
- com.graphql-java:graphql-java (Maven): affected from 20.0; fixed in 20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28867/ (Markdown: https://insights.sbomify.com/CVE-2023-28867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28867
- OSV: https://osv.dev/vulnerability/CVE-2023-28867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28867/
Summaries are generated and may contain mistakes; the official description above is the record.
