{"answers":{"affected":"2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28882 in the wild and no public exploit code.","fix":"Upgrade modsecurity to 3.0.9 or later.","what":"CVE-2023-28882 is a high-severity denial of service vulnerability in n/a, published on 28 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-28882 and fix it if it is affected.\n\nWhat it is: CVE-2023-28882 is a high-severity denial of service vulnerability in n/a, published on 28 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-28882 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- modsecurity (Bitnami): affected from 3.0.5; fixed in 3.0.9\n- modsecurity2 (Bitnami): affected from 3.0.5; fixed in 3.0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28882/ (Markdown: https://insights.sbomify.com/CVE-2023-28882/index.md)","id":"CVE-2023-28882","markdown":"https://insights.sbomify.com/CVE-2023-28882/index.md","name":"CVE-2023-28882","record":{"aliases":["BIT-modsecurity-2023-28882","BIT-modsecurity2-2023-28882","DEBIAN-CVE-2023-28882","GHSA-wgcm-rvmx-wh95","UBUNTU-CVE-2023-28882","openSUSE-SU-2024:12937-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Web application firewall","requires_auth":"none","summary":"Attackers can cause a denial of service by triggering a segmentation fault in ModSecurity, affecting web servers using this firewall.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"modsecurity","vendor":"owasp"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Trustwave ModSecurity 3.0.5 through 3.0.8 before 3.0.9 allows a denial of service (worker crash and unresponsiveness) because some inputs cause a segfault in the Transaction class for some configurations.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2023-28882","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"SQL injection in n/a","id":"CVE-2023-28883"},"packages":[{"ecosystem":"Bitnami","fixed":["3.0.9"],"introduced":["3.0.5"],"last_affected":[],"package":"modsecurity","purl":"pkg:bitnami/modsecurity","source":"BIT-modsecurity-2023-28882"},{"ecosystem":"Bitnami","fixed":["3.0.9"],"introduced":["3.0.5"],"last_affected":[],"package":"modsecurity2","purl":"pkg:bitnami/modsecurity2","source":"BIT-modsecurity2-2023-28882"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2023-28879"},"products":["n/a"],"published":"2023-04-28","related":[{"cvss_score":8.6,"headline":"Security feature bypass in ModSecurity","id":"CVE-2026-52747","kev_date_added":null,"published":"2026-07-10"},{"cvss_score":8.6,"headline":"WAF bypass of the ModSecurity v3 release line","id":"CVE-2024-1019","kev_date_added":null,"published":"2024-01-30"},{"cvss_score":8.2,"headline":"ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators","id":"CVE-2026-42268","kev_date_added":null,"published":"2026-05-12"},{"cvss_score":8.2,"headline":"libModSecurity3 denial of service via segfault when using t:hexDecode on single-character query strings","id":"CVE-2026-30923","kev_date_added":null,"published":"2026-05-05"},{"cvss_score":7.5,"headline":"ModSecurity has possible DoS vulnerability in sanitiseArg action","id":"CVE-2025-48866","kev_date_added":null,"published":"2025-06-02"},{"cvss_score":7.5,"headline":"Trustwave ModSecurity 3.x before 3.0.10 has Inefficient Algorithmic Complexity.","id":"CVE-2023-38285","kev_date_added":null,"published":"2023-07-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-30","vendors":["n/a"]},"summary":"Attackers can cause a denial of service by triggering a segmentation fault in ModSecurity, affecting web servers using this firewall.","url":"https://insights.sbomify.com/CVE-2023-28882/"}