{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.openmeetings:openmeetings-db. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-28936 in the wild and no public exploit code.","fix":"Upgrade org.apache.openmeetings:openmeetings-db to 7.1.0 or later.","what":"CVE-2023-28936 is a medium-severity missing authorization vulnerability in Apache OpenMeetings, published on 12 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-28936 and fix it if it is affected.\n\nWhat it is: CVE-2023-28936 is a medium-severity missing authorization vulnerability in Apache OpenMeetings, published on 12 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-28936 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.openmeetings:openmeetings-db (Maven): affected from 2.0.0; fixed in 7.1.0\n- org.apache.openmeetings:openmeetings-db (Maven): affected from 2.0.0; fixed in 7.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28936/ (Markdown: https://insights.sbomify.com/CVE-2023-28936/index.md)","id":"CVE-2023-28936","markdown":"https://insights.sbomify.com/CVE-2023-28936/index.md","name":"CVE-2023-28936","record":{"aliases":["GHSA-v93h-rwj8-78qh"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache OpenMeetings","requires_auth":"none","summary":"An attacker can access arbitrary recordings or rooms due to insufficient validation of invitation hashes in Apache OpenMeetings.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"openmeetings","vendor":"apache"}],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-697","name":"Incorrect Comparison"}],"description":"Attacker can access arbitrary recording/room\n\nVendor: The Apache Software Foundation\n\nVersions Affected: Apache OpenMeetings from 2.0.0 before 7.1.0","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache OpenMeetings: insufficient check of invitation hash","id":"CVE-2023-28936","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Hardcoded credentials in DataSpider Servista","id":"CVE-2023-28937"},"packages":[{"ecosystem":"Maven","fixed":["7.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.openmeetings:openmeetings-db","purl":null,"source":"GHSA-v93h-rwj8-78qh"},{"ecosystem":"Maven","fixed":["7.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.openmeetings:openmeetings-db","purl":"pkg:maven/org.apache.openmeetings/openmeetings-db","source":"GHSA-v93h-rwj8-78qh"}],"prev":{"headline":"Apache UIMA DUCC: DUCC (EOL) allows RCE","id":"CVE-2023-28935"},"products":["Apache OpenMeetings"],"published":"2023-05-12","related":[{"cvss_score":10,"headline":"Apache OpenMeetings does not correctly validate uploaded XML documents","id":"CVE-2017-7664","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":9.8,"headline":"Apache OpenMeetings: Deserialisation of untrusted data in cluster mode","id":"CVE-2024-54676","kev_date_added":null,"published":"2025-01-08"},{"cvss_score":9.8,"headline":"Apache OpenMeetings: allows user impersonation","id":"CVE-2023-28326","kev_date_added":null,"published":"2023-03-28"},{"cvss_score":9.8,"headline":"Apache OpenMeetings RCE","id":"CVE-2016-8736","kev_date_added":null,"published":"2017-10-12"},{"cvss_score":9.8,"headline":"Apache OpenMeetings has Inadequate Encryption Strength","id":"CVE-2017-7673","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache OpenMeetings vulnerable to Cross-Site Request Forgery","id":"CVE-2017-7666","kev_date_added":null,"published":"2017-07-14"},{"cvss_score":8.8,"headline":"Apache OpenMeetings vulnerable to SQL injection","id":"CVE-2017-7681","kev_date_added":null,"published":"2017-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-10","vendors":["Apache Software Foundation"]},"summary":"An attacker can access arbitrary recordings or rooms due to insufficient validation of invitation hashes in Apache OpenMeetings.","url":"https://insights.sbomify.com/CVE-2023-28936/"}