# CVE-2023-29002: Debug mode leaks confidential data in Cilium

> Attackers with debug access can read sensitive secrets like TLS keys from Cilium logs, enabling traffic interception and modification.

- **Severity:** High 7.2 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2023
- **Updated:** 5 Feb 2025
- **Also known as:** BIT-cilium-2023-29002, BIT-cilium-operator-2023-29002, BIT-cilium-proxy-2023-29002, BIT-hubble-2023-29002, BIT-hubble-relay-2023-29002, BIT-hubble-ui-2023-29002, BIT-hubble-ui-backend-2023-29002, GHSA-pg5p-wwp8-97g8, GO-2023-1730

## What is CVE-2023-29002?

CVE-2023-29002 is a high-severity vulnerability in cilium, published on 18 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. When run in debug mode, Cilium will log the contents of the `cilium-secrets` namespace. This could include data such as TLS private keys for Ingress and GatewayAPI resources. An attacker with access to debug output from the Cilium containers could use the resulting output to intercept and modify traffic to and from the affected cluster. Output of the sensitive information would occur at Cilium agent restart, when secrets in the namespace are modified, and on creation of Ingress or GatewayAPI resources. This vulnerability is fixed in Cilium releases 1.11.16, 1.12.9, and 1.13.2. Users unable to upgrade should disable debug mode.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2023-29002?

16 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | From 1.11.0 | 1.11.16 |
| `github.com/cilium/cilium` | Go | From 1.11.0 | 1.11.16 |
| `github.com/cilium/cilium` | Go | From 1.12.0 | 1.12.9 |
| `github.com/cilium/cilium` | Go | From 1.12.0 | 1.12.9 |
| `github.com/cilium/cilium` | Go | From 1.13.0 | 1.13.2 |
| `github.com/cilium/cilium` | Go | From 1.13.0 | 1.13.2 |
| `github.com/cilium/cilium` | Go | From 1.7.0 | 1.11.16, 1.12.9, 1.13.2 |
| `github.com/cilium/cilium` | Go | From 1.7.0 to 1.10.0 | None |
| `github.com/cilium/cilium` | Go | From 1.7.0 to 1.10.0 | None |
| `cilium` | Bitnami | From 1.7.0 | 1.11.16, 1.12.9, 1.13.2 |
| `cilium-operator` | Bitnami | From 1.7.0 | 1.11.16, 1.12.9, 1.13.2 |
| `cilium-proxy` | Bitnami | From 1.7.0 | 1.11.16, 1.12.9, 1.13.2 |
| `hubble` | Bitnami | From 1.7.0 | 1.11.16, 1.12.9, 1.13.2 |
| `hubble-relay` | Bitnami | From 1.7.0 | 1.11.16, 1.12.9, 1.13.2 |
| `hubble-ui` | Bitnami | From 1.7.0 | 1.11.16, 1.12.9, 1.13.2 |
| `hubble-ui-backend` | Bitnami | From 1.7.0 | 1.11.16, 1.12.9, 1.13.2 |

Products: Cilium Cilium.

## How do I fix CVE-2023-29002?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.11.16, 1.12.9 or 1.13.2.

## Is CVE-2023-29002 being exploited?

There is no known exploitation of CVE-2023-29002 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29002 and fix it if it is affected.

What it is: CVE-2023-29002 is a high-severity vulnerability in cilium, published on 18 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-29002 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected from 1.11.0; fixed in 1.11.16
- github.com/cilium/cilium (Go): affected from 1.11.0; fixed in 1.11.16
- github.com/cilium/cilium (Go): affected from 1.12.0; fixed in 1.12.9
- github.com/cilium/cilium (Go): affected from 1.12.0; fixed in 1.12.9
- github.com/cilium/cilium (Go): affected from 1.13.0; fixed in 1.13.2
- github.com/cilium/cilium (Go): affected from 1.13.0; fixed in 1.13.2
- github.com/cilium/cilium (Go): affected from 1.7.0; fixed in 1.11.16, 1.12.9, 1.13.2
- github.com/cilium/cilium (Go): affected from 1.7.0 up to 1.10.0; no fix listed
- github.com/cilium/cilium (Go): affected from 1.7.0 up to 1.10.0; no fix listed
- cilium (Bitnami): affected from 1.7.0; fixed in 1.11.16, 1.12.9, 1.13.2
- cilium-operator (Bitnami): affected from 1.7.0; fixed in 1.11.16, 1.12.9, 1.13.2
- cilium-proxy (Bitnami): affected from 1.7.0; fixed in 1.11.16, 1.12.9, 1.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29002/ (Markdown: https://insights.sbomify.com/CVE-2023-29002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29002
- OSV: https://osv.dev/vulnerability/CVE-2023-29002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29002/
Summaries are generated and may contain mistakes; the official description above is the record.
