{"answers":{"affected":"2 open source packages ship an affected version, including @sveltejs/kit. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29003 exists.","fix":"Upgrade @sveltejs/kit to 1.15.1 or later.","what":"CVE-2023-29003 is a high-severity vulnerability in sveltejs kit, published on 4 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-29003 and fix it if it is affected.\n\nWhat it is: CVE-2023-29003 is a high-severity vulnerability in sveltejs kit, published on 4 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29003 exists.\n\nAffected packages and fixed versions:\n- @sveltejs/kit (npm): affected all versions; fixed in 1.15.1\n- @sveltejs/kit (npm): affected all versions; fixed in 1.15.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-29003/ (Markdown: https://insights.sbomify.com/CVE-2023-29003/index.md)","id":"CVE-2023-29003","markdown":"https://insights.sbomify.com/CVE-2023-29003/index.md","name":"CVE-2023-29003","record":{"aliases":["GHSA-5p75-vc5g-8rv2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"SvelteKit web framework","requires_auth":"none","summary":"Attackers can bypass CSRF protection in SvelteKit by manipulating Content-Type headers, potentially executing unauthorized actions in victim sessions.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sveltekit","vendor":"svelte"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"},{"id":"CWE-184","name":"Incomplete List of Disallowed Inputs"}],"description":"SvelteKit is a web development framework. The SvelteKit framework offers developers an option to create simple REST APIs. This is done by defining a `+server.js` file, containing endpoint handlers for different HTTP methods.\n\nSvelteKit provides out-of-the-box cross-site request forgery (CSRF) protection to its users. While the implementation does a sufficient job in mitigating common CSRF attacks, prior to version 1.15.1, the protection can be bypassed by simply specifying a different `Content-Type` header value.\n\nIf abused, this issue will allow malicious requests to be submitted from third-party domains, which can allow execution of operations within the context of the victim's session, and in extreme scenarios can lead to unauthorized access to users’ accounts.\n\nSvelteKit 1.15.1 updates the `is_form_content_type` function call in the CSRF protection logic to include `text/plain`. As additional hardening of the CSRF protection mechanism against potential method overrides, SvelteKit 1.15.1 is now performing validation on `PUT`, `PATCH` and `DELETE` methods as well. This latter hardening is only needed to protect users who have put in some sort of `?_method= override` feature themselves in their `handle` hook, so that the request that resolve sees could be `PUT`/`PATCH`/`DELETE` when the browser issues a `POST` request.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"SvelteKit has Insufficient Cross-Site Request Forgery Protection","id":"CVE-2023-29003","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"csrf","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Path Traversal Vulnerability in hap-wi/roxy-wi","id":"CVE-2023-29004"},"packages":[{"ecosystem":"npm","fixed":["1.15.1"],"introduced":["0"],"last_affected":[],"package":"@sveltejs/kit","purl":null,"source":"GHSA-5p75-vc5g-8rv2"},{"ecosystem":"npm","fixed":["1.15.1"],"introduced":["0"],"last_affected":[],"package":"@sveltejs/kit","purl":"pkg:npm/%40sveltejs/kit","source":"GHSA-5p75-vc5g-8rv2"}],"prev":{"headline":"Debug mode leaks confidential data in Cilium","id":"CVE-2023-29002"},"products":["kit"],"published":"2023-04-04","related":[{"cvss_score":8.8,"headline":"SvelteKit framework has Insufficient CSRF protection for CORS requests","id":"CVE-2023-29008","kev_date_added":null,"published":"2023-04-06"},{"cvss_score":8.7,"headline":"SvelteKit 2.49.0 before 2.53.3 Denial of Service via form","id":"CVE-2026-82259","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":8.7,"headline":"SvelteKit before 2.52.2 Memory Exhaustion via Remote Form Deserialization","id":"CVE-2026-82260","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":8.7,"headline":"SvelteKit before 2.52.2 CPU Exhaustion via Remote Form Deserialization","id":"CVE-2026-82261","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":6.9,"headline":"SvelteKit before 2.69.1 Denial of Service via Remote Form","id":"CVE-2026-82256","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":5.9,"headline":"SvelteKit 2.38.0 before 2.60.1 Cross-User Data Disclosure via query.batch","id":"CVE-2026-82258","kev_date_added":null,"published":"2026-08-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-10","vendors":["sveltejs"]},"summary":"Attackers can bypass CSRF protection in SvelteKit by manipulating Content-Type headers, potentially executing unauthorized actions in victim sessions.","url":"https://insights.sbomify.com/CVE-2023-29003/"}