{"answers":{"affected":"3 open source packages ship an affected version, including flask-appbuilder and Flask-AppBuilder. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-29005 in the wild and no public exploit code.","fix":"Upgrade flask-appbuilder to 4.3.0 or later.","what":"CVE-2023-29005 is a high-severity vulnerability in dpgaspar Flask-AppBuilder, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-29005 and fix it if it is affected.\n\nWhat it is: CVE-2023-29005 is a high-severity vulnerability in dpgaspar Flask-AppBuilder, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-29005 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flask-appbuilder (PyPI): affected all versions; fixed in 4.3.0\n- flask-appbuilder (PyPI): affected all versions; fixed in 4.3.0\n- Flask-AppBuilder (PyPI): affected all versions; fixed in 4.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-29005/ (Markdown: https://insights.sbomify.com/CVE-2023-29005/index.md)","id":"CVE-2023-29005","markdown":"https://insights.sbomify.com/CVE-2023-29005/index.md","name":"CVE-2023-29005","record":{"aliases":["GHSA-9hcr-9hcv-x6pv","PYSEC-2026-1380"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Flask web framework library","requires_auth":"none","summary":"Attackers can brute-force user credentials due to missing rate limiting, requiring configuration changes to mitigate.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flask-appbuilder","vendor":"dpgaspar"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-307","name":"Improper Restriction of Excessive Authentication Attempts"}],"description":"Flask-AppBuilder versions before 4.3.0 lack rate limiting which can allow an attacker to brute-force user credentials. Version 4.3.0 includes the ability to enable rate limiting using `AUTH_RATE_LIMITED = True`, `RATELIMIT_ENABLED = True`, and setting an `AUTH_RATE_LIMIT`.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"No Rate Limiting on Login AUTH DB","id":"CVE-2023-29005","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"Order GLPI plugin vulnerable to remote code execution from authenticated user","id":"CVE-2023-29006"},"packages":[{"ecosystem":"PyPI","fixed":["4.3.0"],"introduced":["0"],"last_affected":[],"package":"Flask-AppBuilder","purl":null,"source":"GHSA-9hcr-9hcv-x6pv"},{"ecosystem":"PyPI","fixed":["4.3.0"],"introduced":["0"],"last_affected":[],"package":"flask-appbuilder","purl":"pkg:pypi/flask-appbuilder","source":"GHSA-9hcr-9hcv-x6pv"},{"ecosystem":"PyPI","fixed":["4.3.0"],"introduced":["0"],"last_affected":[],"package":"flask-appbuilder","purl":"pkg:pypi/flask-appbuilder","source":"PYSEC-2026-1380"}],"prev":{"headline":"Path Traversal Vulnerability in hap-wi/roxy-wi","id":"CVE-2023-29004"},"products":["Flask-AppBuilder"],"published":"2023-04-10","related":[{"cvss_score":9.1,"headline":"Flask-AppBuilder incorrect authentication when using auth type OpenID","id":"CVE-2024-25128","kev_date_added":null,"published":"2024-02-28"},{"cvss_score":8.1,"headline":"Improper Authentication in Flask-AppBuilder","id":"CVE-2021-41265","kev_date_added":null,"published":"2021-12-09"},{"cvss_score":7.2,"headline":"URL Redirection to Untrusted Site ('Open Redirect') in Flask-AppBuilder","id":"CVE-2021-32805","kev_date_added":null,"published":"2021-09-08"},{"cvss_score":6.5,"headline":"Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods","id":"CVE-2025-58065","kev_date_added":null,"published":"2025-09-11"},{"cvss_score":6.1,"headline":"Open Redirect in Flask-AppBuilder","id":"CVE-2022-24776","kev_date_added":null,"published":"2022-03-24"},{"cvss_score":5.3,"headline":"Observable Response Discrepancy in Flask-AppBuilder","id":"CVE-2022-21659","kev_date_added":null,"published":"2022-01-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-07","vendors":["dpgaspar"]},"summary":"Attackers can brute-force user credentials due to missing rate limiting, requiring configuration changes to mitigate.","url":"https://insights.sbomify.com/CVE-2023-29005/"}