# CVE-2023-29005: No Rate Limiting on Login AUTH DB

> Attackers can brute-force user credentials due to missing rate limiting, requiring configuration changes to mitigate.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2023
- **Updated:** 7 Feb 2025
- **Also known as:** GHSA-9hcr-9hcv-x6pv, PYSEC-2026-1380

## What is CVE-2023-29005?

CVE-2023-29005 is a high-severity vulnerability in dpgaspar Flask-AppBuilder, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flask-AppBuilder versions before 4.3.0 lack rate limiting which can allow an attacker to brute-force user credentials. Version 4.3.0 includes the ability to enable rate limiting using `AUTH_RATE_LIMITED = True`, `RATELIMIT_ENABLED = True`, and setting an `AUTH_RATE_LIMIT`.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2023-29005?

3 open source packages ship an affected version, including flask-appbuilder and Flask-AppBuilder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-appbuilder` | PyPI | All versions | 4.3.0 |
| `flask-appbuilder` | PyPI | All versions | 4.3.0 |
| `Flask-AppBuilder` | PyPI | All versions | 4.3.0 |

Products: Dpgaspar Flask-Appbuilder.

## How do I fix CVE-2023-29005?

Upgrade flask-appbuilder to 4.3.0 or later.

## Is CVE-2023-29005 being exploited?

There is no known exploitation of CVE-2023-29005 in the wild and no public exploit code.

## Other vulnerabilities in dpgaspar Flask-AppBuilder

- [CVE-2024-25128](https://insights.sbomify.com/CVE-2024-25128/): Flask-AppBuilder incorrect authentication when using auth type OpenID (critical 9.1)
- [CVE-2021-41265](https://insights.sbomify.com/CVE-2021-41265/): Improper Authentication in Flask-AppBuilder (high 8.1)
- [CVE-2021-32805](https://insights.sbomify.com/CVE-2021-32805/): URL Redirection to Untrusted Site ('Open Redirect') in Flask-AppBuilder (high 7.2)
- [CVE-2025-58065](https://insights.sbomify.com/CVE-2025-58065/): Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods (medium 6.5)
- [CVE-2022-24776](https://insights.sbomify.com/CVE-2022-24776/): Open Redirect in Flask-AppBuilder (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29005 and fix it if it is affected.

What it is: CVE-2023-29005 is a high-severity vulnerability in dpgaspar Flask-AppBuilder, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-29005 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-appbuilder (PyPI): affected all versions; fixed in 4.3.0
- flask-appbuilder (PyPI): affected all versions; fixed in 4.3.0
- Flask-AppBuilder (PyPI): affected all versions; fixed in 4.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29005/ (Markdown: https://insights.sbomify.com/CVE-2023-29005/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29005
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29005
- OSV: https://osv.dev/vulnerability/CVE-2023-29005

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29005/
Summaries are generated and may contain mistakes; the official description above is the record.
