# CVE-2023-29008: SvelteKit framework has Insufficient CSRF protection for CORS requests

> Attackers can bypass CSRF protection in SvelteKit by using uppercase Content-Type headers, allowing unauthorized actions in victim sessions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Apr 2023
- **Updated:** 10 Feb 2025
- **Also known as:** GHSA-gv7g-x59x-wf8f

## What is CVE-2023-29008?

CVE-2023-29008 is a high-severity vulnerability in sveltejs kit, published on 6 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The SvelteKit framework offers developers an option to create simple REST APIs. This is done by defining a `+server.js` file, containing endpoint handlers for different HTTP methods.

SvelteKit provides out-of-the-box cross-site request forgery (CSRF) protection to its users. The protection is implemented at `kit/src/runtime/server/respond.js`. While the implementation does a sufficient job of mitigating common CSRF attacks, the protection can be bypassed in versions prior to 1.15.2 by simply specifying an upper-cased `Content-Type` header value. The browser will not send uppercase characters, but this check does not block all expected CORS requests.

If abused, this issue will allow malicious requests to be submitted from third-party domains, which can allow execution of operations within the context of the victim's session, and in extreme scenarios can lead to unauthorized access to users’ accounts. This may lead to all POST operations requiring authentication being allowed in the following cases: If the target site sets `SameSite=None` on its auth cookie and the user visits a malicious site in a Chromium-based browser; if the target site doesn't set the `SameSite` attribute explicitly and the user visits a malicious site with Firefox/Safari with tracking protections turned off; and/or if the user is visiting a malicious site with a very outdated browser.

SvelteKit 1.15.2 contains a patch for this issue. It is also recommended to explicitly set `SameSite` to a value other than `None` on authentication cookies especially if the upgrade cannot be done in a timely manner.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-29008?

2 open source packages ship an affected version, including @sveltejs/kit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sveltejs/kit` | npm | All versions | 1.15.2 |
| `@sveltejs/kit` | npm | All versions | 1.15.2 |

Products: Svelte Sveltekit.

## How do I fix CVE-2023-29008?

Upgrade @sveltejs/kit to 1.15.2 or later.

## Is CVE-2023-29008 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29008 exists.

## Other vulnerabilities in sveltejs kit

- [CVE-2023-29003](https://insights.sbomify.com/CVE-2023-29003/): SvelteKit has Insufficient Cross-Site Request Forgery Protection (high 8.8)
- [CVE-2026-82259](https://insights.sbomify.com/CVE-2026-82259/): SvelteKit 2.49.0 before 2.53.3 Denial of Service via form (high 8.7)
- [CVE-2026-82260](https://insights.sbomify.com/CVE-2026-82260/): SvelteKit before 2.52.2 Memory Exhaustion via Remote Form Deserialization (high 8.7)
- [CVE-2026-82261](https://insights.sbomify.com/CVE-2026-82261/): SvelteKit before 2.52.2 CPU Exhaustion via Remote Form Deserialization (high 8.7)
- [CVE-2026-82256](https://insights.sbomify.com/CVE-2026-82256/): SvelteKit before 2.69.1 Denial of Service via Remote Form (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29008 and fix it if it is affected.

What it is: CVE-2023-29008 is a high-severity vulnerability in sveltejs kit, published on 6 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29008 exists.

Affected packages and fixed versions:
- @sveltejs/kit (npm): affected all versions; fixed in 1.15.2
- @sveltejs/kit (npm): affected all versions; fixed in 1.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29008/ (Markdown: https://insights.sbomify.com/CVE-2023-29008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29008
- OSV: https://osv.dev/vulnerability/CVE-2023-29008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29008/
Summaries are generated and may contain mistakes; the official description above is the record.
