{"answers":{"affected":"2 open source packages ship an affected version, including io.goobi.viewer:viewer-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-29014 in the wild and no public exploit code.","fix":"Upgrade io.goobi.viewer:viewer-core to 23.03 or later.","what":"CVE-2023-29014 is a medium-severity cross-site scripting vulnerability in intranda goobi-viewer-core, published on 6 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-29014 and fix it if it is affected.\n\nWhat it is: CVE-2023-29014 is a medium-severity cross-site scripting vulnerability in intranda goobi-viewer-core, published on 6 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-29014 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.goobi.viewer:viewer-core (Maven): affected all versions; fixed in 23.03\n- io.goobi.viewer:viewer-core (Maven): affected all versions; fixed in 23.03\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-29014/ (Markdown: https://insights.sbomify.com/CVE-2023-29014/index.md)","id":"CVE-2023-29014","markdown":"https://insights.sbomify.com/CVE-2023-29014/index.md","name":"CVE-2023-29014","record":{"aliases":["GHSA-7v7g-9vx6-vcg2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Goobi viewer core","requires_auth":"none","summary":"An attacker can execute malicious scripts in a user's browser via a crafted link exploiting the LOGID parameter in Goobi viewer.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"goobi_viewer_core","vendor":"intranda"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Goobi viewer is a web application that allows digitised material to be displayed in a web browser. A reflected cross-site scripting vulnerability has been identified in Goobi viewer core prior to version 23.03 when evaluating the LOGID parameter. An attacker could trick a user into following a specially crafted link to a Goobi viewer installation, resulting in the execution of malicious script code in the user's browser. The vulnerability has been fixed in version 23.03.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Goobi viewer Core Reflected Cross-Site Scripting Vulnerability Using LOGID Parameter","id":"CVE-2023-29014","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Goobi viewer Core has Cross-Site Scripting Vulnerability in User Comments","id":"CVE-2023-29015"},"packages":[{"ecosystem":"Maven","fixed":["23.03"],"introduced":["0"],"last_affected":[],"package":"io.goobi.viewer:viewer-core","purl":null,"source":"GHSA-7v7g-9vx6-vcg2"},{"ecosystem":"Maven","fixed":["23.03"],"introduced":["0"],"last_affected":[],"package":"io.goobi.viewer:viewer-core","purl":"pkg:maven/io.goobi.viewer/viewer-core","source":"GHSA-7v7g-9vx6-vcg2"}],"prev":{"headline":"HTTP header parsing could cause a deny of service","id":"CVE-2023-29013"},"products":["goobi-viewer-core"],"published":"2023-04-06","related":[{"cvss_score":9.6,"headline":"Path traversal in Goobi viewer Core","id":"CVE-2020-15124","kev_date_added":null,"published":"2020-07-22"},{"cvss_score":6.1,"headline":"Goobi viewer Core has Cross-Site Scripting Vulnerability in User Comments","id":"CVE-2023-29015","kev_date_added":null,"published":"2023-04-06"},{"cvss_score":6.1,"headline":"Goobi viewer Core has Cross-Site Scripting Vulnerability in User Nicknames","id":"CVE-2023-29016","kev_date_added":null,"published":"2023-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-10","vendors":["intranda"]},"summary":"An attacker can execute malicious scripts in a user's browser via a crafted link exploiting the LOGID parameter in Goobi viewer.","url":"https://insights.sbomify.com/CVE-2023-29014/"}