# CVE-2023-29015: Goobi viewer Core has Cross-Site Scripting Vulnerability in User Comments

> An attacker can execute malicious scripts in a user's browser via crafted comments in the Goobi viewer web application.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Apr 2023
- **Updated:** 10 Feb 2025
- **Also known as:** GHSA-622w-995c-3c3h

## What is CVE-2023-29015?

CVE-2023-29015 is a medium-severity cross-site scripting vulnerability in intranda goobi-viewer-core, published on 6 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Goobi viewer is a web application that allows digitised material to be displayed in a web browser. A cross-site scripting vulnerability has been identified in the user comment feature of Goobi viewer core prior to version 23.03. An attacker could create a specially crafted comment, resulting in the execution of malicious script code in the user's browser when displaying the comment. The vulnerability has been fixed in version 23.03.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-29015?

2 open source packages ship an affected version, including io.goobi.viewer:viewer-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.goobi.viewer:viewer-core` | Maven | All versions | 23.03 |
| `io.goobi.viewer:viewer-core` | Maven | All versions | 23.03 |

Products: Intranda Goobi Viewer Core.

## How do I fix CVE-2023-29015?

Upgrade io.goobi.viewer:viewer-core to 23.03 or later.

## Is CVE-2023-29015 being exploited?

There is no known exploitation of CVE-2023-29015 in the wild and no public exploit code.

## Other vulnerabilities in intranda goobi-viewer-core

- [CVE-2020-15124](https://insights.sbomify.com/CVE-2020-15124/): Path traversal in Goobi viewer Core (critical 9.6)
- [CVE-2023-29014](https://insights.sbomify.com/CVE-2023-29014/): Goobi viewer Core Reflected Cross-Site Scripting Vulnerability Using LOGID Parameter (medium 6.1)
- [CVE-2023-29016](https://insights.sbomify.com/CVE-2023-29016/): Goobi viewer Core has Cross-Site Scripting Vulnerability in User Nicknames (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29015 and fix it if it is affected.

What it is: CVE-2023-29015 is a medium-severity cross-site scripting vulnerability in intranda goobi-viewer-core, published on 6 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-29015 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.goobi.viewer:viewer-core (Maven): affected all versions; fixed in 23.03
- io.goobi.viewer:viewer-core (Maven): affected all versions; fixed in 23.03

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29015/ (Markdown: https://insights.sbomify.com/CVE-2023-29015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29015
- OSV: https://osv.dev/vulnerability/CVE-2023-29015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29015/
Summaries are generated and may contain mistakes; the official description above is the record.
