# CVE-2023-29017: vm2 Sandbox Escape vulnerability

> Attackers can bypass sandbox protections to execute arbitrary code on the host via improper handling of async errors in vm2.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2023
- **Updated:** 10 Feb 2025
- **Also known as:** GHSA-7jxr-cg7f-gpgv, ROOT-APP-NPM-CVE-2023-29017

## What is CVE-2023-29017?

CVE-2023-29017 is a critical code injection vulnerability in patriksimek vm2, published on 6 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 is a sandbox that can run untrusted code with whitelisted Node's built-in modules. Prior to version 3.9.15, vm2 was not properly handling host objects passed to `Error.prepareStackTrace` in case of unhandled async errors. A threat actor could bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version 3.9.15 of vm2. There are no known workarounds.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2023-29017?

2 open source packages ship an affected version, including vm2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.9.15 |
| `vm2` | npm | All versions | 3.9.15 |

Products: Vm2 Project Vm2.

## How do I fix CVE-2023-29017?

Upgrade vm2 to 3.9.15 or later.

## Is CVE-2023-29017 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29017 exists.

Public exploit code:

- Clone from gist (github_poc): https://github.com/timb-machine-mirrors/seongil-wi-CVE-2023-29017
- https://github.com/passwa11/CVE-2023-29017-reverse-shell (github_poc): https://github.com/passwa11/CVE-2023-29017-reverse-shell
- Node.js vm2 CVE-2023-29017 reproduction with Docker Compose and PoC (github_poc): https://github.com/gunwoo105/Node_CVE-2023-29017

## Other vulnerabilities in patriksimek vm2

- [CVE-2026-43997](https://insights.sbomify.com/CVE-2026-43997/): vm2: Sandbox Escape (critical 10.0)
- [CVE-2026-44005](https://insights.sbomify.com/CVE-2026-44005/): vm2: Sandbox escape (critical 10.0)
- [CVE-2026-44006](https://insights.sbomify.com/CVE-2026-44006/): vm2: Sandbox Escape (critical 10.0)
- [CVE-2022-36067](https://insights.sbomify.com/CVE-2022-36067/): vm2 vulnerable to Sandbox Escape before v3.9.11 (critical 10.0)
- [CVE-2026-43999](https://insights.sbomify.com/CVE-2026-43999/): vm2: NodeVM builtin allowlist bypass via `module` builtin's `Module._load` allows sandbox escape (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29017 and fix it if it is affected.

What it is: CVE-2023-29017 is a critical code injection vulnerability in patriksimek vm2, published on 6 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29017 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.9.15
- vm2 (npm): affected all versions; fixed in 3.9.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29017/ (Markdown: https://insights.sbomify.com/CVE-2023-29017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29017
- OSV: https://osv.dev/vulnerability/CVE-2023-29017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29017/
Summaries are generated and may contain mistakes; the official description above is the record.
