CVE-2023-2905 Cesanta Mongoose MQTT Message Parsing Heap Overflow

High 8.8 Published Updated

A heap-based buffer overflow in Cesanta Mongoose allows attackers to execute arbitrary code or cause denial of service via crafted MQTT messages.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2023-2905?

CVE-2023-2905 is a high-severity memory corruption vulnerability in Cesanta Mongoose, published on 9 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.

Weakness: CWE-787, CWE-122

Which versions are affected by CVE-2023-2905?

It affects 1 product.

Products include Cesanta Mongoose.

How do I fix CVE-2023-2905?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2023-2905 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2905 exists.

All Cesanta Mongoose vulnerabilities

Sources

Also known as DEBIAN-CVE-2023-2905, GHSA-pv78-3m65-h826, UBUNTU-CVE-2023-2905.

Is CVE-2023-2905 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free