# CVE-2023-2905: Cesanta Mongoose MQTT Message Parsing Heap Overflow

> A heap-based buffer overflow in Cesanta Mongoose allows attackers to execute arbitrary code or cause denial of service via crafted MQTT messages.

- **Severity:** High 8.8 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2023
- **Updated:** 10 Oct 2024
- **Also known as:** DEBIAN-CVE-2023-2905, GHSA-pv78-3m65-h826, UBUNTU-CVE-2023-2905

## What is CVE-2023-2905?

CVE-2023-2905 is a high-severity memory corruption vulnerability in Cesanta Mongoose, published on 9 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2023-2905?

It affects 1 product.


Products: Cesanta Mongoose.

## How do I fix CVE-2023-2905?

Upgrade to a fixed version.

## Is CVE-2023-2905 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2905 exists.

## Other vulnerabilities in Cesanta Mongoose

- [CVE-2022-25299](https://insights.sbomify.com/CVE-2022-25299/): Arbitrary File Write (critical 9.8)
- [CVE-2020-25756](https://insights.sbomify.com/CVE-2020-25756/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-19307](https://insights.sbomify.com/CVE-2019-19307/): Integer overflow in n/a (critical 9.8)
- [CVE-2019-12951](https://insights.sbomify.com/CVE-2019-12951/): Memory corruption in n/a (critical 9.8)
- [CVE-2018-20353](https://insights.sbomify.com/CVE-2018-20353/): Use after free in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2905 and fix it if it is affected.

What it is: CVE-2023-2905 is a high-severity memory corruption vulnerability in Cesanta Mongoose, published on 9 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2905 exists.

Affected product: Cesanta Mongoose. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2905/ (Markdown: https://insights.sbomify.com/CVE-2023-2905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2905
- OSV: https://osv.dev/vulnerability/CVE-2023-2905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2905/
Summaries are generated and may contain mistakes; the official description above is the record.
