CVE-2023-29055 Apache Kylin: Insufficiently protected credentials in config file
Attackers can sniff HTTP traffic to steal credentials from the Kylin Server Config interface if HTTPS is not enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-29055?
CVE-2023-29055 is a high-severity vulnerability in Apache Kylin, published on 29 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Apache Kylin version 2.0.0 to 4.0.3, there is a Server Config web interface that displays the content of file 'kylin.properties', that may contain serverside credentials. When the kylin service runs over HTTP (or other plain text protocol), it is possible for network sniffers to hijack the HTTP payload and get access to the content of kylin.properties and potentially the containing credentials.
To avoid this threat, users are recommended to
* Always turn on HTTPS so that network payload is encrypted.
* Avoid putting credentials in kylin.properties, or at least not in plain text. * Use network firewalls to protect the serverside such that it is not accessible to external attackers.
* Upgrade to version Apache Kylin 4.0.4, which filters out the sensitive content that goes to the Server Config web interface.
Weakness: CWE-522
Which versions are affected by CVE-2023-29055?
2 open source packages ship an affected version, including org.apache.kylin:kylin-core-common. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.kylin:kylin-core-common Maven | From 2.0.0 | 4.0.4 |
org.apache.kylin:kylin-core-common Maven | From 2.0.0 | 4.0.4 |
Products include Apache Kylin.
How do I fix CVE-2023-29055?
Upgrade org.apache.kylin:kylin-core-common to 4.0.4 or later.
Is CVE-2023-29055 being exploited?
There is no known exploitation of CVE-2023-29055 in the wild and no public exploit code.
Other vulnerabilities in Apache Kylin
- CVE-2020-1956 Apache Kylin OS Command Injection
- CVE-2026-62390 Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API
- CVE-2022-44621 Apache Kylin: Command injection by Diagnosis Controller
- CVE-2022-24697 Apache Kylin vulnerable to remote code execution
- CVE-2021-31522 Apache Kylin unsafe class loading
Sources
Also known as GHSA-3vvc-v8c2-43r7.