# CVE-2023-29055: Apache Kylin: Insufficiently protected credentials in config file

> Attackers can sniff HTTP traffic to steal credentials from the Kylin Server Config interface if HTTPS is not enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2024
- **Updated:** 20 Jun 2025
- **Also known as:** GHSA-3vvc-v8c2-43r7

## What is CVE-2023-29055?

CVE-2023-29055 is a high-severity vulnerability in Apache Kylin, published on 29 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Kylin version 2.0.0 to 4.0.3, there is a Server Config web interface that displays the content of file 'kylin.properties', that may contain serverside credentials. When the kylin service runs over HTTP (or other plain text protocol), it is possible for network sniffers to hijack the HTTP payload and get access to the content of kylin.properties and potentially the containing credentials.

To avoid this threat, users are recommended to 

  *  Always turn on HTTPS so that network payload is encrypted.

  *  Avoid putting credentials in kylin.properties, or at least not in plain text.
  *  Use network firewalls to protect the serverside such that it is not accessible to external attackers.

  *  Upgrade to version Apache Kylin 4.0.4, which filters out the sensitive content that goes to the Server Config web interface.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2023-29055?

2 open source packages ship an affected version, including org.apache.kylin:kylin-core-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kylin:kylin-core-common` | Maven | From 2.0.0 | 4.0.4 |
| `org.apache.kylin:kylin-core-common` | Maven | From 2.0.0 | 4.0.4 |

Products: Apache Kylin.

## How do I fix CVE-2023-29055?

Upgrade org.apache.kylin:kylin-core-common to 4.0.4 or later.

## Is CVE-2023-29055 being exploited?

There is no known exploitation of CVE-2023-29055 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kylin

- [CVE-2020-1956](https://insights.sbomify.com/CVE-2020-1956/): Apache Kylin OS Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-62390](https://insights.sbomify.com/CVE-2026-62390/): Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API (critical 9.8)
- [CVE-2022-44621](https://insights.sbomify.com/CVE-2022-44621/): Apache Kylin: Command injection by Diagnosis Controller (critical 9.8)
- [CVE-2022-24697](https://insights.sbomify.com/CVE-2022-24697/): Apache Kylin vulnerable to remote code execution (critical 9.8)
- [CVE-2021-31522](https://insights.sbomify.com/CVE-2021-31522/): Apache Kylin unsafe class loading (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29055 and fix it if it is affected.

What it is: CVE-2023-29055 is a high-severity vulnerability in Apache Kylin, published on 29 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-29055 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kylin:kylin-core-common (Maven): affected from 2.0.0; fixed in 4.0.4
- org.apache.kylin:kylin-core-common (Maven): affected from 2.0.0; fixed in 4.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29055/ (Markdown: https://insights.sbomify.com/CVE-2023-29055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29055
- OSV: https://osv.dev/vulnerability/CVE-2023-29055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29055/
Summaries are generated and may contain mistakes; the official description above is the record.
