# CVE-2023-29139: Denial of service in n/a

> Authenticated users with checkuser permissions can cause denial of service via excessive API requests in specific configurations.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2023
- **Updated:** 14 Feb 2025
- **Also known as:** BIT-mediawiki-2023-29139, GHSA-j4f5-gw7r-fr82

## What is CVE-2023-29139?

CVE-2023-29139 is a medium-severity denial of service vulnerability in Mediawiki Mediawiki, published on 31 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in the CheckUser extension for MediaWiki through 1.39.3. When a user with checkuserlog permissions makes many CheckUserLog API requests in some configurations, denial of service can occur (RequestTimeoutException or upstream request timeout).

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-29139?

1 open source package ship an affected version, including mediawiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.39.4 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2023-29139?

Upgrade mediawiki to 1.39.4 or later.

## Is CVE-2023-29139 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29139 exists.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29139 and fix it if it is affected.

What it is: CVE-2023-29139 is a medium-severity denial of service vulnerability in Mediawiki Mediawiki, published on 31 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29139 exists.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.39.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29139/ (Markdown: https://insights.sbomify.com/CVE-2023-29139/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29139
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29139
- OSV: https://osv.dev/vulnerability/CVE-2023-29139

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29139/
Summaries are generated and may contain mistakes; the official description above is the record.
