# CVE-2023-29141: X-Forwarded-For header allows brute-forcing autoblocked IP addresses

> Attackers can bypass IP-based blocking mechanisms by spoofing the X-Forwarded-For header, allowing unauthorized access or actions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2023
- **Updated:** 18 Feb 2025
- **Also known as:** BIT-mediawiki-2023-29141, DEBIAN-CVE-2023-29141, DLA-3540-1, GHSA-5vj8-g3qg-4qh6, UBUNTU-CVE-2023-29141

## What is CVE-2023-29141?

CVE-2023-29141 is a critical vulnerability in Fedoraproject Fedora, published on 31 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in MediaWiki before 1.35.10, 1.36.x through 1.38.x before 1.38.6, and 1.39.x before 1.39.3. An auto-block can occur for an untrusted X-Forwarded-For header.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2023-29141?

7 open source packages ship an affected version, including mediawiki/core and mediawiki. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/core` | Packagist | All versions | 1.35.10 |
| `mediawiki/core` | Packagist | All versions | 1.35.10 |
| `mediawiki/core` | Packagist | From 1.38.0 | 1.38.6 |
| `mediawiki/core` | Packagist | From 1.38.0 | 1.38.6 |
| `mediawiki/core` | Packagist | From 1.39.0 | 1.39.3 |
| `mediawiki/core` | Packagist | From 1.39.0 | 1.39.3 |
| `mediawiki` | Bitnami | All versions | 1.35.10, 1.38.6, 1.39.3 |

Products: Fedoraproject Fedora, Mediawiki Mediawiki.

## How do I fix CVE-2023-29141?

Upgrade mediawiki/core to a fixed version for your release line: 1.35.10, 1.38.6 or 1.39.3.

## Is CVE-2023-29141 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29141 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29141 and fix it if it is affected.

What it is: CVE-2023-29141 is a critical vulnerability in Fedoraproject Fedora, published on 31 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29141 exists.

Affected packages and fixed versions:
- mediawiki/core (Packagist): affected all versions; fixed in 1.35.10
- mediawiki/core (Packagist): affected all versions; fixed in 1.35.10
- mediawiki/core (Packagist): affected from 1.38.0; fixed in 1.38.6
- mediawiki/core (Packagist): affected from 1.38.0; fixed in 1.38.6
- mediawiki/core (Packagist): affected from 1.39.0; fixed in 1.39.3
- mediawiki/core (Packagist): affected from 1.39.0; fixed in 1.39.3
- mediawiki (Bitnami): affected all versions; fixed in 1.35.10, 1.38.6, 1.39.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29141/ (Markdown: https://insights.sbomify.com/CVE-2023-29141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29141
- OSV: https://osv.dev/vulnerability/CVE-2023-29141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29141/
Summaries are generated and may contain mistakes; the official description above is the record.
