# CVE-2023-29200: contao/core-bundle has path traversal vulnerability in the file manager

> Authenticated attackers can list arbitrary system files via the file manager, exposing directory structures without reading file contents.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2023
- **Updated:** 3 Feb 2025
- **Also known as:** GHSA-fp7q-xhhw-6rj3

## What is CVE-2023-29200?

CVE-2023-29200 is a medium-severity path traversal vulnerability in contao, published on 25 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Contao is an open source content management system. Prior to versions 4.9.40, 4.13.21, and 5.1.4, logged in users can list arbitrary system files in the file manager by manipulating the Ajax request. However, it is not possible to read the contents of these files. Users should update to Contao 4.9.40, 4.13.21 or 5.1.4 to receive a patch. There are no known workarounds.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-29200?

6 open source packages ship an affected version, including contao/contao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/contao` | Packagist | From 4.13.0 | 4.13.21 |
| `contao/contao` | Packagist | From 4.13.0 | 4.13.21 |
| `contao/contao` | Packagist | From 4.9.0 | 4.9.40 |
| `contao/contao` | Packagist | From 4.9.0 | 4.9.40 |
| `contao/contao` | Packagist | From 5.1.0 | 5.1.4 |
| `contao/contao` | Packagist | From 5.1.0 | 5.1.4 |

Products: Contao Contao.

## How do I fix CVE-2023-29200?

Upgrade contao/contao to a fixed version for your release line: 4.13.21, 4.9.40 or 5.1.4.

## Is CVE-2023-29200 being exploited?

There is no known exploitation of CVE-2023-29200 in the wild and no public exploit code.

## Other vulnerabilities in contao

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2019-19745](https://insights.sbomify.com/CVE-2019-19745/): Unrestricted file uploads in Contao (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29200 and fix it if it is affected.

What it is: CVE-2023-29200 is a medium-severity path traversal vulnerability in contao, published on 25 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-29200 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/contao (Packagist): affected from 4.13.0; fixed in 4.13.21
- contao/contao (Packagist): affected from 4.13.0; fixed in 4.13.21
- contao/contao (Packagist): affected from 4.9.0; fixed in 4.9.40
- contao/contao (Packagist): affected from 4.9.0; fixed in 4.9.40
- contao/contao (Packagist): affected from 5.1.0; fixed in 5.1.4
- contao/contao (Packagist): affected from 5.1.0; fixed in 5.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29200/ (Markdown: https://insights.sbomify.com/CVE-2023-29200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29200
- OSV: https://osv.dev/vulnerability/CVE-2023-29200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29200/
Summaries are generated and may contain mistakes; the official description above is the record.
