# CVE-2023-29201: org.xwiki.commons:xwiki-commons-xml Cross-site Scripting vulnerability

> Insufficient HTML sanitization in restricted mode allows XSS, enabling server-side code execution when privileged users view malicious comments.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Apr 2023
- **Updated:** 6 Feb 2025
- **Also known as:** GHSA-m3jr-cvhj-f35j

## What is CVE-2023-29201?

CVE-2023-29201 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 15 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Commons are technical libraries common to several other top level XWiki projects. The "restricted" mode of the HTML cleaner in XWiki, introduced in version 4.2-milestone-1, only escaped `<script>` and `<style>`-tags but neither attributes that can be used to inject scripts nor other dangerous HTML tags like `<iframe>`. As a consequence, any code relying on this "restricted" mode for security is vulnerable to JavaScript injection ("cross-site scripting"/XSS). When a privileged user with programming rights visits such a comment in XWiki, the malicious JavaScript code is executed in the context of the user session. This allows server-side code execution with programming rights, impacting the confidentiality, integrity and availability of the XWiki instance. This problem has been patched in XWiki 14.6 RC1 with the introduction of a filter with allowed HTML elements and attributes that is enabled in restricted mode. There are no known workarounds apart from upgrading to a version including the fix.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-29201?

2 open source packages ship an affected version, including org.xwiki.commons:xwiki-commons-xml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.commons:xwiki-commons-xml` | Maven | From 4.2-milestone-1 | 14.6-rc-1 |
| `org.xwiki.commons:xwiki-commons-xml` | Maven | From 4.2-milestone-1 | 14.6-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-29201?

Upgrade org.xwiki.commons:xwiki-commons-xml to 14.6-rc-1 or later.

## Is CVE-2023-29201 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29201 exists.

Public exploit code:

- https://github.com/shoucheng3/xwiki__xwiki-commons_CVE-2023-29201_14-5 (github_poc): https://github.com/shoucheng3/xwiki__xwiki-commons_CVE-2023-29201_14-5

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29201 and fix it if it is affected.

What it is: CVE-2023-29201 is a critical cross-site scripting vulnerability in Xwiki Xwiki, published on 15 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29201 exists.

Affected packages and fixed versions:
- org.xwiki.commons:xwiki-commons-xml (Maven): affected from 4.2-milestone-1; fixed in 14.6-rc-1
- org.xwiki.commons:xwiki-commons-xml (Maven): affected from 4.2-milestone-1; fixed in 14.6-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29201/ (Markdown: https://insights.sbomify.com/CVE-2023-29201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29201
- OSV: https://osv.dev/vulnerability/CVE-2023-29201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29201/
Summaries are generated and may contain mistakes; the official description above is the record.
