# CVE-2023-29204: URL Redirection to Untrusted Site ('Open Redirect') in org.xwiki.platform:xwiki-platform-oldcore

> Attackers can bypass open redirect protections in XWiki Commons to redirect users to untrusted sites, requiring an upgrade to patched versions.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Apr 2023
- **Updated:** 6 Feb 2025
- **Also known as:** GHSA-xwph-x6xj-wggv

## What is CVE-2023-29204?

CVE-2023-29204 is a medium-severity vulnerability in Xwiki Xwiki, published on 15 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Commons are technical libraries common to several other top level XWiki projects. It is possible to bypass the existing security measures put in place to avoid open redirect by using a redirect such as `//mydomain.com` (i.e. omitting the `http:`). It was also possible to bypass it when using URL such as `http:/mydomain.com`. The problem has been patched on XWiki 13.10.10, 14.4.4 and 14.8RC1.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2023-29204?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0-rc-1 | 14.4.4 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0-rc-1 | 14.4.4 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.5 | 14.8-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.5 | 14.8-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 6.0-rc-1 | 13.10.10 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 6.0-rc-1 | 13.10.10 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-29204?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 14.4.4, 14.8-rc-1 or 13.10.10.

## Is CVE-2023-29204 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29204 exists.

Public exploit code:

- XWiki - Open Redirect (nuclei): http/cves/2023/CVE-2023-29204.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29204 and fix it if it is affected.

What it is: CVE-2023-29204 is a medium-severity vulnerability in Xwiki Xwiki, published on 15 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29204 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0-rc-1; fixed in 14.4.4
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0-rc-1; fixed in 14.4.4
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.5; fixed in 14.8-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.5; fixed in 14.8-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 6.0-rc-1; fixed in 13.10.10
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 6.0-rc-1; fixed in 13.10.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29204/ (Markdown: https://insights.sbomify.com/CVE-2023-29204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29204
- OSV: https://osv.dev/vulnerability/CVE-2023-29204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29204/
Summaries are generated and may contain mistakes; the official description above is the record.
