# CVE-2023-29208: Data leak through deleted documents

> Attackers can view deleted documents that had view rights, bypassing intended access restrictions in XWiki Commons.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2023
- **Updated:** 6 Feb 2025
- **Also known as:** GHSA-4f8g-fq6x-jqrr

## What is CVE-2023-29208?

CVE-2023-29208 is a high-severity vulnerability in Xwiki Xwiki, published on 15 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Commons are technical libraries common to several other top level XWiki projects. Rights added to a document are not taken into account for viewing it once it's deleted. Note that this vulnerability only impact deleted documents that where containing view rights: the view rights provided on a space of a deleted document are properly checked. The problem has been patched in XWiki 14.10 by checking the rights of current user: only admin and deleter of the document are allowed to view it.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2023-29208?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.2-milestone-1 | 13.10.11 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 1.2-milestone-1 | 13.10.11 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0-rc-1 | 14.4.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0-rc-1 | 14.4.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.5 | 14.10 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.5 | 14.10 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-29208?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 13.10.11, 14.4.7 or 14.10.

## Is CVE-2023-29208 being exploited?

There is no known exploitation of CVE-2023-29208 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29208 and fix it if it is affected.

What it is: CVE-2023-29208 is a high-severity vulnerability in Xwiki Xwiki, published on 15 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-29208 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.2-milestone-1; fixed in 13.10.11
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.2-milestone-1; fixed in 13.10.11
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0-rc-1; fixed in 14.4.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0-rc-1; fixed in 14.4.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.5; fixed in 14.10
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.5; fixed in 14.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29208/ (Markdown: https://insights.sbomify.com/CVE-2023-29208/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29208
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29208
- OSV: https://osv.dev/vulnerability/CVE-2023-29208

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29208/
Summaries are generated and may contain mistakes; the official description above is the record.
