# CVE-2023-29213: org.xwiki.platform:xwiki-platform-logging-ui Injection vulnerability

> An attacker can trick a user with programming rights into visiting a crafted URL to execute arbitrary code within the XWiki logging UI component.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Apr 2023
- **Updated:** 5 Feb 2025
- **Also known as:** GHSA-4655-wh7v-3vmg

## What is CVE-2023-29213?

CVE-2023-29213 is a critical code injection vulnerability in Xwiki Xwiki, published on 17 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions of `org.xwiki.platform:xwiki-platform-logging-ui` it is possible to trick a user with programming rights into visiting a constructed url where e.g., by embedding an image with this URL in a document that is viewed by a user with programming rights which will evaluate an expression in the constructed url and execute it. This issue has been addressed in versions 13.10.11, 14.4.7, and 14.10. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-29213?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-logging-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-logging-ui` | Maven | From 14.0-rc-1 | 14.4.7 |
| `org.xwiki.platform:xwiki-platform-logging-ui` | Maven | From 14.0-rc-1 | 14.4.7 |
| `org.xwiki.platform:xwiki-platform-logging-ui` | Maven | From 14.5 | 14.10 |
| `org.xwiki.platform:xwiki-platform-logging-ui` | Maven | From 14.5 | 14.10 |
| `org.xwiki.platform:xwiki-platform-logging-ui` | Maven | From 4.2-milestone-3 | 13.10.11 |
| `org.xwiki.platform:xwiki-platform-logging-ui` | Maven | From 4.2-milestone-3 | 13.10.11 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-29213?

Upgrade org.xwiki.platform:xwiki-platform-logging-ui to a fixed version for your release line: 14.4.7, 14.10 or 13.10.11.

## Is CVE-2023-29213 being exploited?

There is no known exploitation of CVE-2023-29213 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29213 and fix it if it is affected.

What it is: CVE-2023-29213 is a critical code injection vulnerability in Xwiki Xwiki, published on 17 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-29213 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-logging-ui (Maven): affected from 14.0-rc-1; fixed in 14.4.7
- org.xwiki.platform:xwiki-platform-logging-ui (Maven): affected from 14.0-rc-1; fixed in 14.4.7
- org.xwiki.platform:xwiki-platform-logging-ui (Maven): affected from 14.5; fixed in 14.10
- org.xwiki.platform:xwiki-platform-logging-ui (Maven): affected from 14.5; fixed in 14.10
- org.xwiki.platform:xwiki-platform-logging-ui (Maven): affected from 4.2-milestone-3; fixed in 13.10.11
- org.xwiki.platform:xwiki-platform-logging-ui (Maven): affected from 4.2-milestone-3; fixed in 13.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29213/ (Markdown: https://insights.sbomify.com/CVE-2023-29213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29213
- OSV: https://osv.dev/vulnerability/CVE-2023-29213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29213/
Summaries are generated and may contain mistakes; the official description above is the record.
