CVE-2023-29215 Apache Linkis JDBC EngineCon has a deserialization command execution

Critical 9.8 Published Updated

An attacker can achieve remote code execution in Apache Linkis by configuring malicious MySQL JDBC parameters that trigger a deserialization vulnerability.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-29215?

CVE-2023-29215 is a critical unsafe deserialization vulnerability in Apache Linkis, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Apache Linkis <=1.3.1, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in JDBC EengineConn Module will trigger a deserialization vulnerability and eventually lead to remote code execution. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.

Weakness: CWE-502

Which versions are affected by CVE-2023-29215?

2 open source packages ship an affected version, including org.apache.linkis:linkis-engineconn. It affects 1 product.

PackageAffectedFixed in
org.apache.linkis:linkis-engineconn MavenAll versions1.3.2
org.apache.linkis:linkis-engineconn MavenAll versions1.3.2

Products include Apache Linkis.

How do I fix CVE-2023-29215?

Upgrade org.apache.linkis:linkis-engineconn to 1.3.2 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2023-29215 being exploited?

There is no known exploitation of CVE-2023-29215 in the wild and no public exploit code.

Sources

Also known as GHSA-qm2h-m799-86rc.

Is CVE-2023-29215 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free