# CVE-2023-29215: Apache Linkis JDBC EngineCon has a deserialization command execution

> An attacker can achieve remote code execution in Apache Linkis by configuring malicious MySQL JDBC parameters that trigger a deserialization vulnerability.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-qm2h-m799-86rc

## What is CVE-2023-29215?

CVE-2023-29215 is a critical unsafe deserialization vulnerability in Apache Linkis, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Linkis <=1.3.1, due to the lack of effective filtering
of parameters, an attacker configuring malicious Mysql JDBC parameters in JDBC EengineConn Module will trigger a
deserialization vulnerability and eventually lead to remote code execution. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected.
We recommend users upgrade the version of Linkis to version 1.3.2.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-29215?

2 open source packages ship an affected version, including org.apache.linkis:linkis-engineconn. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.linkis:linkis-engineconn` | Maven | All versions | 1.3.2 |
| `org.apache.linkis:linkis-engineconn` | Maven | All versions | 1.3.2 |

Products: Apache Linkis.

## How do I fix CVE-2023-29215?

Upgrade org.apache.linkis:linkis-engineconn to 1.3.2 or later.

## Is CVE-2023-29215 being exploited?

There is no known exploitation of CVE-2023-29215 in the wild and no public exploit code.

## Other vulnerabilities in Apache Linkis

- [CVE-2023-27602](https://insights.sbomify.com/CVE-2023-27602/): Apache Linkis publicsercice module unrestricted upload of file (critical 9.8)
- [CVE-2023-27603](https://insights.sbomify.com/CVE-2023-27603/): Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue (critical 9.8)
- [CVE-2023-29216](https://insights.sbomify.com/CVE-2023-29216/): Apache Linkis DatasourceManager module has a deserialization command execution (critical 9.8)
- [CVE-2023-27987](https://insights.sbomify.com/CVE-2023-27987/): Apache Linkis gateway module token authentication bypass (critical 9.1)
- [CVE-2024-27181](https://insights.sbomify.com/CVE-2024-27181/): Apache Linkis Basic management services: Privilege Escalation Attack vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29215 and fix it if it is affected.

What it is: CVE-2023-29215 is a critical unsafe deserialization vulnerability in Apache Linkis, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-29215 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.linkis:linkis-engineconn (Maven): affected all versions; fixed in 1.3.2
- org.apache.linkis:linkis-engineconn (Maven): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29215/ (Markdown: https://insights.sbomify.com/CVE-2023-29215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29215
- OSV: https://osv.dev/vulnerability/CVE-2023-29215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29215/
Summaries are generated and may contain mistakes; the official description above is the record.
