CVE-2023-29216 Apache Linkis DatasourceManager module has a deserialization command execution

Critical 9.8 Published Updated

Attackers can achieve remote code execution in Apache Linkis by exploiting a deserialization vulnerability in the DatasourceManager module via malicious MySQL parameters.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-29216?

CVE-2023-29216 is a critical unsafe deserialization vulnerability in Apache Linkis, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.

Weakness: CWE-502

Which versions are affected by CVE-2023-29216?

2 open source packages ship an affected version, including org.apache.linkis:linkis-datasource. It affects 1 product.

PackageAffectedFixed in
org.apache.linkis:linkis-datasource MavenAll versions1.3.2
org.apache.linkis:linkis-datasource MavenAll versions1.3.2

Products include Apache Linkis.

How do I fix CVE-2023-29216?

Upgrade org.apache.linkis:linkis-datasource to 1.3.2 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2023-29216 being exploited?

There is no known exploitation of CVE-2023-29216 in the wild and no public exploit code.

Sources

Also known as GHSA-rrhf-32rq-f28h.

Is CVE-2023-29216 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free