CVE-2023-29234 Bypass serialize checks in Apache Dubbo

Critical 9.8 Published Updated

Attackers can execute arbitrary code by sending malicious serialized packages to Apache Dubbo services, requiring an upgrade to the latest version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-29234?

CVE-2023-29234 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4.

Users are recommended to upgrade to the latest version, which fixes the issue.

Weakness: CWE-502

Which versions are affected by CVE-2023-29234?

4 open source packages ship an affected version, including org.apache.dubbo:dubbo. It affects 1 product.

PackageAffectedFixed in
org.apache.dubbo:dubbo MavenFrom 3.1.03.1.11
org.apache.dubbo:dubbo MavenFrom 3.1.03.1.11
org.apache.dubbo:dubbo MavenFrom 3.2.03.2.5
org.apache.dubbo:dubbo MavenFrom 3.2.03.2.5

Products include Apache Dubbo.

How do I fix CVE-2023-29234?

Upgrade org.apache.dubbo:dubbo to a fixed version for your release line: 3.1.11 or 3.2.5.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2023-29234 being exploited?

There is no known exploitation of CVE-2023-29234 in the wild and no public exploit code.

Sources

Also known as GHSA-6x49-w35h-wqrj.

Is CVE-2023-29234 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free