{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.dubbo:dubbo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-29234 in the wild and no public exploit code.","fix":"Upgrade org.apache.dubbo:dubbo to a fixed version for your release line: 3.1.11 or 3.2.5.","what":"CVE-2023-29234 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-29234 and fix it if it is affected.\n\nWhat it is: CVE-2023-29234 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-29234 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.dubbo:dubbo (Maven): affected from 3.1.0; fixed in 3.1.11\n- org.apache.dubbo:dubbo (Maven): affected from 3.1.0; fixed in 3.1.11\n- org.apache.dubbo:dubbo (Maven): affected from 3.2.0; fixed in 3.2.5\n- org.apache.dubbo:dubbo (Maven): affected from 3.2.0; fixed in 3.2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-29234/ (Markdown: https://insights.sbomify.com/CVE-2023-29234/index.md)","id":"CVE-2023-29234","markdown":"https://insights.sbomify.com/CVE-2023-29234/index.md","name":"CVE-2023-29234","record":{"aliases":["GHSA-6x49-w35h-wqrj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Java RPC framework","requires_auth":"none","summary":"Attackers can execute arbitrary code by sending malicious serialized packages to Apache Dubbo services, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"dubbo","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4.\n\nUsers are recommended to upgrade to the latest version, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Bypass serialize checks in Apache Dubbo","id":"CVE-2023-29234","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2023"},"n_packages":4,"n_references":2,"next":{"headline":"WordPress Maintenance Switch Plugin \u003c= 1.5.2 is vulnerable to Cross Site Request Forgery (CSRF)","id":"CVE-2023-29235"},"packages":[{"ecosystem":"Maven","fixed":["3.1.11"],"introduced":["3.1.0"],"last_affected":[],"package":"org.apache.dubbo:dubbo","purl":null,"source":"GHSA-6x49-w35h-wqrj"},{"ecosystem":"Maven","fixed":["3.1.11"],"introduced":["3.1.0"],"last_affected":[],"package":"org.apache.dubbo:dubbo","purl":"pkg:maven/org.apache.dubbo/dubbo","source":"GHSA-6x49-w35h-wqrj"},{"ecosystem":"Maven","fixed":["3.2.5"],"introduced":["3.2.0"],"last_affected":[],"package":"org.apache.dubbo:dubbo","purl":null,"source":"GHSA-6x49-w35h-wqrj"},{"ecosystem":"Maven","fixed":["3.2.5"],"introduced":["3.2.0"],"last_affected":[],"package":"org.apache.dubbo:dubbo","purl":"pkg:maven/org.apache.dubbo/dubbo","source":"GHSA-6x49-w35h-wqrj"}],"prev":{"headline":"Business logic in n/a","id":"CVE-2023-29218"},"products":["Apache Dubbo"],"published":"2023-12-15","related":[{"cvss_score":9.8,"headline":"Apache Dubbo: Bypass deny serialize list check in Apache Dubbo","id":"CVE-2023-46279","kev_date_added":null,"published":"2023-12-15"},{"cvss_score":9.8,"headline":"Regular expression Denial of Service in MooTools","id":"CVE-2021-32824","kev_date_added":null,"published":"2023-01-03"},{"cvss_score":9.8,"headline":"Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass","id":"CVE-2022-39198","kev_date_added":null,"published":"2022-10-18"},{"cvss_score":9.8,"headline":"Dubbo Hessian cause RCE when parse error","id":"CVE-2021-43297","kev_date_added":null,"published":"2022-01-10"},{"cvss_score":9.8,"headline":"Unprotected input value toString cause RCE","id":"CVE-2021-36161","kev_date_added":null,"published":"2021-09-09"},{"cvss_score":9.8,"headline":"Bypass deserialization checks in Apache Dubbo","id":"CVE-2021-37579","kev_date_added":null,"published":"2021-09-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary code by sending malicious serialized packages to Apache Dubbo services, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2023-29234/"}