# CVE-2023-29234: Bypass serialize checks in Apache Dubbo

> Attackers can execute arbitrary code by sending malicious serialized packages to Apache Dubbo services, requiring an upgrade to the latest version.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-6x49-w35h-wqrj

## What is CVE-2023-29234?

CVE-2023-29234 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A deserialization vulnerability existed when decode a malicious package.This issue affects Apache Dubbo: from 3.1.0 through 3.1.10, from 3.2.0 through 3.2.4.

Users are recommended to upgrade to the latest version, which fixes the issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-29234?

4 open source packages ship an affected version, including org.apache.dubbo:dubbo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dubbo:dubbo` | Maven | From 3.1.0 | 3.1.11 |
| `org.apache.dubbo:dubbo` | Maven | From 3.1.0 | 3.1.11 |
| `org.apache.dubbo:dubbo` | Maven | From 3.2.0 | 3.2.5 |
| `org.apache.dubbo:dubbo` | Maven | From 3.2.0 | 3.2.5 |

Products: Apache Dubbo.

## How do I fix CVE-2023-29234?

Upgrade org.apache.dubbo:dubbo to a fixed version for your release line: 3.1.11 or 3.2.5.

## Is CVE-2023-29234 being exploited?

There is no known exploitation of CVE-2023-29234 in the wild and no public exploit code.

## Other vulnerabilities in Apache Dubbo

- [CVE-2023-46279](https://insights.sbomify.com/CVE-2023-46279/): Apache Dubbo: Bypass deny serialize list check in Apache Dubbo (critical 9.8)
- [CVE-2021-32824](https://insights.sbomify.com/CVE-2021-32824/): Regular expression Denial of Service in MooTools (critical 9.8)
- [CVE-2022-39198](https://insights.sbomify.com/CVE-2022-39198/): Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass (critical 9.8)
- [CVE-2021-43297](https://insights.sbomify.com/CVE-2021-43297/): Dubbo Hessian cause RCE when parse error (critical 9.8)
- [CVE-2021-36161](https://insights.sbomify.com/CVE-2021-36161/): Unprotected input value toString cause RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29234 and fix it if it is affected.

What it is: CVE-2023-29234 is a critical unsafe deserialization vulnerability in Apache Dubbo, published on 15 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-29234 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dubbo:dubbo (Maven): affected from 3.1.0; fixed in 3.1.11
- org.apache.dubbo:dubbo (Maven): affected from 3.1.0; fixed in 3.1.11
- org.apache.dubbo:dubbo (Maven): affected from 3.2.0; fixed in 3.2.5
- org.apache.dubbo:dubbo (Maven): affected from 3.2.0; fixed in 3.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29234/ (Markdown: https://insights.sbomify.com/CVE-2023-29234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29234
- OSV: https://osv.dev/vulnerability/CVE-2023-29234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29234/
Summaries are generated and may contain mistakes; the official description above is the record.
