# CVE-2023-29287: Adobe Commerce Information Exposure Security feature bypass

> An attacker can leak minor user data and bypass security features in Adobe Commerce without user interaction.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2023
- **Updated:** 5 Mar 2025
- **Also known as:** GHSA-85m4-g9vq-xpxj

## What is CVE-2023-29287?

CVE-2023-29287 is a medium-severity vulnerability in Adobe Commerce, published on 15 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Adobe Commerce versions 2.4.6 (and earlier), 2.4.5-p2 (and earlier) and 2.4.4-p3 (and earlier) are affected by an Information Exposure vulnerability that could lead to a security feature bypass. An attacker could leverage this vulnerability to leak minor user data. Exploitation of this issue does not require user interaction..

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-29287?

8 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | From 2.4.4-p1 | 2.4.4-p4 |
| `magento/community-edition` | Packagist | From 2.4.4-p1 | 2.4.4-p4 |
| `magento/community-edition` | Packagist | From 2.4.5-p1 | 2.4.5-p3 |
| `magento/community-edition` | Packagist | From 2.4.5-p1 | 2.4.5-p3 |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Adobe Commerce, Adobe Magento.

## How do I fix CVE-2023-29287?

Upgrade magento/community-edition to a fixed version for your release line: 2.4.4-p4 or 2.4.5-p3.

## Is CVE-2023-29287 being exploited?

There is no known exploitation of CVE-2023-29287 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Commerce

- [CVE-2026-75650](https://insights.sbomify.com/CVE-2026-75650/): Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine (critical 10.0, exploited in the wild)
- [CVE-2024-34102](https://insights.sbomify.com/CVE-2024-34102/): Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE) (critical 9.8, exploited in the wild)
- [CVE-2022-24086](https://insights.sbomify.com/CVE-2022-24086/): Adobe Commerce and Magento Open Source Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-48356](https://insights.sbomify.com/CVE-2026-48356/): Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type (critical 9.3, exploited in the wild)
- [CVE-2026-71362](https://insights.sbomify.com/CVE-2026-71362/): Adobe Commerce and Magento Incorrect Authorization Vulnerability (critical 9.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29287 and fix it if it is affected.

What it is: CVE-2023-29287 is a medium-severity vulnerability in Adobe Commerce, published on 15 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-29287 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected from 2.4.4-p1; fixed in 2.4.4-p4
- magento/community-edition (Packagist): affected from 2.4.4-p1; fixed in 2.4.4-p4
- magento/community-edition (Packagist): affected from 2.4.5-p1; fixed in 2.4.5-p3
- magento/community-edition (Packagist): affected from 2.4.5-p1; fixed in 2.4.5-p3
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29287/ (Markdown: https://insights.sbomify.com/CVE-2023-29287/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29287
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29287
- OSV: https://osv.dev/vulnerability/CVE-2023-29287

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29287/
Summaries are generated and may contain mistakes; the official description above is the record.
