CVE-2023-29293 Adobe Commerce | Improper Input Validation (CWE-20)
An admin attacker can bypass security features to disrupt a minor feature's availability in Adobe Commerce without user interaction.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-29293?
CVE-2023-29293 is a low-severity vulnerability in Adobe Commerce, published on 15 Jun 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Adobe Commerce versions 2.4.6 (and earlier), 2.4.5-p2 (and earlier) and 2.4.4-p3 (and earlier) are affected by an Improper Input Validation vulnerability that could result in a Security feature bypass. An admin privileged attacker could leverage this vulnerability to impact the availability of a user's minor feature. Exploitation of this issue does not require user interaction.
Weakness: CWE-20
Which versions are affected by CVE-2023-29293?
8 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | None |
magento/community-edition Packagist | All versions | None |
magento/community-edition Packagist | From 2.4.4-p1 | 2.4.4-p4 |
magento/community-edition Packagist | From 2.4.4-p1 | 2.4.4-p4 |
magento/community-edition Packagist | From 2.4.5-p1 | 2.4.5-p3 |
magento/community-edition Packagist | From 2.4.5-p1 | 2.4.5-p3 |
2 more packages
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Adobe Commerce, Adobe Magento.
How do I fix CVE-2023-29293?
Upgrade magento/community-edition to a fixed version for your release line: 2.4.4-p4 or 2.4.5-p3.
Is CVE-2023-29293 being exploited?
There is no known exploitation of CVE-2023-29293 in the wild and no public exploit code.
Other vulnerabilities in Adobe Commerce
- CVE-2026-75650 Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine
- CVE-2024-34102 Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE)
- CVE-2022-24086 Adobe Commerce and Magento Open Source Improper Input Validation
- CVE-2026-48356 Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type
- CVE-2026-71362 Adobe Commerce and Magento Incorrect Authorization Vulnerability
Sources
Also known as GHSA-66c9-xrwj-9xv6.