# CVE-2023-29374: LangChain vulnerable to code injection


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Apr 2023
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-fprp-p869-w6q2, PYSEC-2023-18

## What is CVE-2023-29374?

CVE-2023-29374 is a critical vulnerability in n/a, published on 5 Apr 2023. 

### Official description

In LangChain through 0.0.131, the LLMMathChain chain allows prompt injection attacks that can execute arbitrary code via the Python exec method.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2023-29374?

3 open source packages ship an affected version, including langchain. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain` | PyPI | All versions to 0.0.131 | None |
| `langchain` | PyPI | All versions to 0.0.131 | None |
| `langchain` | PyPI | All versions | 0.0.132 |

Products: Langchain Langchain.

## How do I fix CVE-2023-29374?

Upgrade langchain to 0.0.132 or later.

## Is CVE-2023-29374 being exploited?

There is no known exploitation of CVE-2023-29374 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29374 and fix it if it is affected.

What it is: CVE-2023-29374 is a critical vulnerability in n/a, published on 5 Apr 2023. 
Exploitation: There is no known exploitation of CVE-2023-29374 in the wild and no public exploit code.

Affected packages and fixed versions:
- langchain (PyPI): affected all versions up to 0.0.131; no fix listed
- langchain (PyPI): affected all versions up to 0.0.131; no fix listed
- langchain (PyPI): affected all versions; fixed in 0.0.132

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29374/ (Markdown: https://insights.sbomify.com/CVE-2023-29374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29374
- OSV: https://osv.dev/vulnerability/CVE-2023-29374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29374/
Summaries are generated and may contain mistakes; the official description above is the record.
