{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2023-29476 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-29476 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-29476 is a critical vulnerability in n/a, published on 14 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-29476 and fix it if it is affected.\n\nWhat it is: CVE-2023-29476 is a critical vulnerability in n/a, published on 14 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-29476 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-29476/ (Markdown: https://insights.sbomify.com/CVE-2023-29476/index.md)","id":"CVE-2023-29476","markdown":"https://insights.sbomify.com/CVE-2023-29476/index.md","name":"CVE-2023-29476","record":{"aliases":["GHSA-php5-h4gr-q7j6"],"analysis":{"component_type":"network_device","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Menlo On-Premise Appliance","requires_auth":"none","summary":"Attackers can bypass web policy enforcement on Menlo On-Premise Appliances by sending intentionally malformed client requests.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"In Menlo On-Premise Appliance before 2.88, web policy may not be consistently applied properly to intentionally malformed client requests. This is fixed in 2.88.2+, 2.89.1+, and 2.90.1+.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Security feature bypass in n/a","id":"CVE-2023-29476","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2023"},"n_packages":0,"n_references":1,"next":{"headline":"Path traversal in n/a","id":"CVE-2023-29478"},"packages":[],"prev":{"headline":"Command injection in n/a","id":"CVE-2023-29475"},"products":["n/a"],"published":"2024-12-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-12-16","vendors":["n/a"]},"summary":"Attackers can bypass web policy enforcement on Menlo On-Premise Appliances by sending intentionally malformed client requests.","url":"https://insights.sbomify.com/CVE-2023-29476/"}