# CVE-2023-29476: Security feature bypass in n/a

> Attackers can bypass web policy enforcement on Menlo On-Premise Appliances by sending intentionally malformed client requests.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Dec 2024
- **Updated:** 16 Dec 2024
- **Also known as:** GHSA-php5-h4gr-q7j6

## What is CVE-2023-29476?

CVE-2023-29476 is a critical vulnerability in n/a, published on 14 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Menlo On-Premise Appliance before 2.88, web policy may not be consistently applied properly to intentionally malformed client requests. This is fixed in 2.88.2+, 2.89.1+, and 2.90.1+.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2023-29476?


## How do I fix CVE-2023-29476?

No fix has been published for CVE-2023-29476 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-29476 being exploited?

There is no known exploitation of CVE-2023-29476 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29476 and fix it if it is affected.

What it is: CVE-2023-29476 is a critical vulnerability in n/a, published on 14 Dec 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-29476 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29476/ (Markdown: https://insights.sbomify.com/CVE-2023-29476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29476
- OSV: https://osv.dev/vulnerability/CVE-2023-29476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29476/
Summaries are generated and may contain mistakes; the official description above is the record.
