CVE-2023-29489 Cross-site scripting in n/a
Cross-site scripting in cPanel's cpsrvd error page allows attackers to inject scripts via invalid webcall IDs, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2023-29489?
CVE-2023-29489 is a medium-severity cross-site scripting vulnerability in Cpanel Cpanel, published on 27 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
An issue was discovered in cPanel before 11.109.9999.116. XSS can occur on the cpsrvd error page via an invalid webcall ID, aka SEC-669. The fixed versions are 11.109.9999.116, 11.108.0.13, 11.106.0.18, and 11.102.0.31.
Weakness: CWE-79
Which versions are affected by CVE-2023-29489?
It affects 1 product.
Products include Cpanel Cpanel.
How do I fix CVE-2023-29489?
No fix has been published for CVE-2023-29489 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-29489 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29489 exists.
Public exploit code: 1 Nuclei template and 17 proofs of concept on GitHub.
Other vulnerabilities in Cpanel Cpanel
- CVE-2026-41940 WebPros cPanel & WHM and WP2 (WordPress Squared) Missing Authentication for Critical Function
- CVE-2003-1425 guestbook.cgi in cPanel 5.0 allows remote attackers to execute arbitrary commands via the template parameter.
- CVE-2004-1769 Code injection in n/a
- CVE-2004-1770 Command injection in n/a
- CVE-2020-26098 Command injection in n/a
Sources
Also known as GHSA-84fm-c8wr-cf69.