# CVE-2023-29489: Cross-site scripting in n/a

> Cross-site scripting in cPanel's cpsrvd error page allows attackers to inject scripts via invalid webcall IDs, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.3 (`CVSS:3.1/AC:L/AV:L/A:L/C:L/I:L/PR:L/S:U/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Apr 2023
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-84fm-c8wr-cf69

## What is CVE-2023-29489?

CVE-2023-29489 is a medium-severity cross-site scripting vulnerability in Cpanel Cpanel, published on 27 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in cPanel before 11.109.9999.116. XSS can occur on the cpsrvd error page via an invalid webcall ID, aka SEC-669. The fixed versions are 11.109.9999.116, 11.108.0.13, 11.106.0.18, and 11.102.0.31.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-29489?

It affects 1 product.


Products: Cpanel Cpanel.

## How do I fix CVE-2023-29489?

No fix has been published for CVE-2023-29489 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-29489 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29489 exists.

Public exploit code:

- Mass Scaning vulnerability in Cpanel [XSS]  (github_poc): https://github.com/0-d3y/CVE-2023-29489
- To filter the actual vulnerable URLs from the screenshots, you can use the ee.sh script. Simply run ./ee.sh -f "path/to/index_screenshot.txt" -k "hacked" and the script will filter the URLs that contain the reflective XSS payload (For Example: cPanel CVE-2023-29489 ) in their screenshots. (github_poc): https://github.com/whalebone7/EagleEye
- cpanel_xss_2023 is a simple Python script designed for finding CVE-2023-29489 vulnerability in cpanel. (github_poc): https://github.com/mdaseem03/cpanel_xss_2023
- https://github.com/xKore123/cPanel-CVE-2023-29489 (github_poc): https://github.com/xKore123/cPanel-CVE-2023-29489
- a pyhton script to test all results from shodan for cPanel CVE-2023-29489, credits to @assetnote, I just automate (github_poc): https://github.com/ipk1/CVE-2023-29489.py
- https://github.com/Makurorororororororo/Validate-CVE-2023-29489-scanner- (github_poc): https://github.com/Makurorororororororo/Validate-CVE-2023-29489-scanner-

## Other vulnerabilities in Cpanel Cpanel

- [CVE-2026-41940](https://insights.sbomify.com/CVE-2026-41940/): WebPros cPanel & WHM and WP2 (WordPress Squared) Missing Authentication for Critical Function (critical 9.3, exploited in the wild)
- [CVE-2003-1425](https://insights.sbomify.com/CVE-2003-1425/): guestbook.cgi in cPanel 5.0 allows remote attackers to execute arbitrary commands via the template parameter. (critical 10.0)
- [CVE-2004-1769](https://insights.sbomify.com/CVE-2004-1769/): Code injection in n/a (critical 10.0)
- [CVE-2004-1770](https://insights.sbomify.com/CVE-2004-1770/): Command injection in n/a (critical 10.0)
- [CVE-2020-26098](https://insights.sbomify.com/CVE-2020-26098/): Command injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-29489 and fix it if it is affected.

What it is: CVE-2023-29489 is a medium-severity cross-site scripting vulnerability in Cpanel Cpanel, published on 27 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-29489 exists.

Affected product: Cpanel Cpanel. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-29489/ (Markdown: https://insights.sbomify.com/CVE-2023-29489/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-29489
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-29489
- OSV: https://osv.dev/vulnerability/CVE-2023-29489

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-29489/
Summaries are generated and may contain mistakes; the official description above is the record.
